1 Reply Latest reply on Dec 1, 2005 8:45 AM by js8523

    jbpm @CreateProcess with custom object going into process in

    js8523 Novice

      Hi All

      Is it possible to placing a custom object (e.g. @Entity class UserDefined { }object) into the process instance, for the next stage in the process to pick up and work on.

      All the examples in Seam store the object in persistence and pass a reference to the object through the process instance, is it possible to just pass the object through the process instance as I don't want to place the object in the database untill I have done at least the second step in the process.

      I get this stack trace when I try to do this via:

      @Out(scope=ScopeType.PROCESS)
      private Contact contact;


      Caused by: javax.ejb.EJBTransactionRolledbackException: null; CausedByException is:
       null
       at org.jboss.ejb3.tx.Ejb3TxPolicy.handleInCallerTx(Ejb3TxPolicy.java:65)
       at org.jboss.aspects.tx.TxPolicy.invokeInCallerTx(TxPolicy.java:117)
       at org.jboss.aspects.tx.TxInterceptor$Required.invoke(TxInterceptor.java:138)
       at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:98)
       at org.jboss.aspects.tx.TxPropagationInterceptor.invoke(TxPropagationInterceptor.java:61)
       at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:98)
       at org.jboss.ejb3.stateless.StatelessInstanceInterceptor.invoke(StatelessInstanceInterceptor.java:39)
       at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:98)
       at org.jboss.aspects.security.AuthenticationInterceptor.invoke(AuthenticationInterceptor.java:63)
       at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:98)
       at org.jboss.ejb3.ENCPropagationInterceptor.invoke(ENCPropagationInterceptor.java:32)
       at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:98)
       at org.jboss.ejb3.asynchronous.AsynchronousInterceptor.invoke(AsynchronousInterceptor.java:91)
       at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:98)
       at org.jboss.ejb3.stateless.StatelessContainer.localInvoke(StatelessContainer.java:148)
       at org.jboss.ejb3.stateless.StatelessLocalProxy.invoke(StatelessLocalProxy.java:60)
       at $Proxy124.registerContact(Unknown Source)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:585)
       at org.apache.myfaces.el.MethodBindingImpl.invoke(MethodBindingImpl.java:129)
       ... 29 more



        • 1. Re: jbpm @CreateProcess with custom object going into proces
          js8523 Novice

          Hi All

          A little update.. I have investigated this problem further, and it is unrelated to the variables "outjected" into the process instance. The problem is actually with the lookup of the ManagedJBpmSession (whilst invoking the @CreateProcess.

          The jbpm session it retrieves is null.

          I've got the startup listener as per the dvd store (with the process xml def changed). This works, I see the output on deploy. I've checked the jndi view and the jbpmsessionfactory is bound, but when the invoker hoes to fetch it, it returns a null session.

          Any help, anyone.

          I've deployed the dvd.ear and it works perfectly. I've tried using the exact same jars but still the same error. I am currently using jbpm 3.0.1 and jboss seam from cvs.

          Many thanks,

          James