3 Replies Latest reply on Jan 3, 2006 6:25 PM by Gavin King

    Breaking change

    Gavin King Master

      I finally got round to deciding what I wanted to do about

      http://jira.jboss.com/jira/browse/JBSEAM-79

      The choice I made is to, by default, throw an exception when an @Begin method is called in the scope of an existing conversation.

      This is the best default, since the risk of having unrelated conversations "accidently" propagated is a just too high, and results in very subtle bugs.

      If you want to get the previous default behavior, where the existing conversation context is simply propagated, just say @Begin(join=true)

      Sorry for the breakage here.

      Does anyone strongly disagree with my cost/benefit analysis here?

      Can anyone think of a much more intuitive name for this than join() ?