5 Replies Latest reply on Jan 26, 2006 12:11 PM by Max Rydahl Andersen

    Seam reverse engineering tool problem

    Stefan Liebner Newbie

      Hi folks,

      I currently have a problem using your seam reverse engineering tool.

      When I use the tool under eclipse, I get the following exception:

      Exception while generating code

      Reason:
      org.hibernate.console.HibernateConsoleRuntimeException: Could not create or find with one argument delegate constructor
      java.lang.ClassNotFoundException:
      java.lang.ClassNotFoundException:


      Not really helpfull, don't know what is missing

      My Config:
      -Latest jboss ide release from 2006 with eclipse bundle
      -current JDK 1.5.0_06
      -current seam version from nightly build site
      -got head and 4.0.x jboss from cvs and put jars in lib dir
      -tried generator with adding lib files to project and without (just in lib dir)
      -all hibernate config files seem to be OK
      -connection to DB with schema is OK, I see the tables and can select erverything for the reverse engineering file

      I tried several variations in the generator settings dialog. There is nothing I can generate. Every single option will lead to the same message. I stripped the schema I want to generate down to a minimum of two tables.

      Actually I'm not even sure if it is not a general generator issue.

      But maybe I'm just missing a very simple point.

      Help please,
      Stefan