3 Replies Latest reply on Nov 19, 2008 7:47 PM by Nick Belaevski

    Internet Explorer issues

    Peter Sowerbutts Newbie

      Hi, I'm currently developing an app with several large ajax-ified components. For example we have a rich:tree which has 400+ nodes that can be selected and added to a list.
      The process of display, selecting and rerendering the chosen node list takes about 12seconds per request in IE7. When loading this page in Firefox the process runs straight away with no visible lag!

      IE8 beta 2 fixes these performance problems, running as fast as Firefox, but it does not render a lot of the richfaces components properly, especially modal panels. (see live demo page in IE8 - http://livedemo.exadel.com/richfaces-demo/richfaces/modalPanel.jsf?c=modalPanel&tab=usage)

      My company only supports IE so switching target platform to Firefox is not an option.

      So I was wondering if
      1) Are there anyways to speed up the IE7 performance?

      2) Are there plans to fix the look of richfaces in IE8? (I have the latest nightly build)

      Thanks for any help, Pete

        • 1. Re: Internet Explorer issues
          Ilya Shaikovsky Master

          1) which filter you using in your application?

          2) We still not started support checking because this is unreleased version.

          • 2. Re: Internet Explorer issues
            Peter Sowerbutts Newbie

            Heres my web.xml, theres a couple of filters in there, am I missing one though?

            <?xml version="1.0" encoding="UTF-8"?>
            <web-app version="2.5"
             xmlns="http://java.sun.com/xml/ns/javaee"
             xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
             xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd">
            
             <!-- Seam Listener listens for /*.seam in the context and forwards to faces
             with the default suffix as defined (xhtml) Faces Servlet then does the
             faces specific stuff prior to rendering. -->
            
             <!-- Seam -->
             <listener>
             <listener-class>org.jboss.seam.servlet.SeamListener</listener-class>
             </listener>
            
             <filter>
             <filter-name>Seam Filter</filter-name>
             <filter-class>org.jboss.seam.servlet.SeamFilter</filter-class>
             </filter>
            
             <filter-mapping>
             <filter-name>Seam Filter</filter-name>
             <url-pattern>/*</url-pattern>
             </filter-mapping>
            
             <servlet>
             <servlet-name>Seam Resource Servlet</servlet-name>
             <servlet-class>org.jboss.seam.servlet.SeamResourceServlet</servlet-class>
             </servlet>
            
             <servlet-mapping>
             <servlet-name>Seam Resource Servlet</servlet-name>
             <url-pattern>/seam/resource/*</url-pattern>
             </servlet-mapping>
            
             <!-- Faces Servlet -->
             <servlet>
             <servlet-name>Faces Servlet</servlet-name>
             <servlet-class>javax.faces.webapp.FacesServlet</servlet-class>
             <load-on-startup>1</load-on-startup>
             </servlet>
            
             <servlet-mapping>
             <servlet-name>Faces Servlet</servlet-name>
             <url-pattern>*.seam</url-pattern>
             </servlet-mapping>
            
             <!-- JSF parameters -->
            
             <context-param>
             <param-name>javax.faces.DEFAULT_SUFFIX</param-name>
             <param-value>.xhtml</param-value>
             </context-param>
            
             <context-param>
             <param-name>facelets.DEVELOPMENT</param-name>
             <param-value>true</param-value>
             </context-param>
            
             <session-config>
             <session-timeout>10</session-timeout>
             </session-config>
            
             <context-param>
             <param-name>org.jboss.seam.core.init.debug</param-name>
             <param-value>true</param-value>
             </context-param>
            
             <!-- Facestrace -->
            
             <context-param>
             <param-name>com.prime.facestrace.DISABLE_TRACE</param-name>
             <param-value>false</param-value>
             </context-param>
            
            
             <!-- RichFaces -->
             <context-param>
             <param-name>org.richfaces.SKIN</param-name>
             <param-value>#{skinBean.skin}</param-value>
             </context-param>
            
             <filter>
             <display-name>RichFaces Filter</display-name>
             <filter-name>richfaces</filter-name>
             <filter-class>org.ajax4jsf.Filter</filter-class>
             </filter>
            
             <filter-mapping>
             <filter-name>richfaces</filter-name>
             <servlet-name>Faces Servlet</servlet-name>
             <dispatcher>REQUEST</dispatcher>
             <dispatcher>FORWARD</dispatcher>
             <dispatcher>INCLUDE</dispatcher>
             </filter-mapping>
            
            </web-app>
            


            • 3. Re: Internet Explorer issues
              Nick Belaevski Master

              Pete,

              Try to change filter used by this init parameter:

              <context-param>
               <param-name>org.ajax4jsf.xmlparser.ORDER</param-name>
               <param-value>NEKO</param-value>
               </context-param>


              Possible values are NONE, NEKO, TIDY