10 Replies Latest reply on Oct 4, 2006 7:24 PM by Max Rydahl Andersen

    Seam reverse engineering tool

    josh krupka Newbie

      I'm trying to use the Seam CRUD tool to get a simple app up against a mysql db... it deploys ok until it hits the seam init stuff, then here's what happens...

      08:39:51,743 INFO [Initialization] reading properties from: /seam.properties
      08:39:51,743 INFO [Initialization] reading properties from: /jndi.properties
      08:39:51,743 INFO [Initialization] initializing Seam
      08:39:51,868 INFO [Component] Component: org.jboss.seam.core.init, scope: APPLICATION, type: JAVA_BEAN, class: org.jboss.seam.core.Init
      08:39:51,868 ERROR [[/seamapp]] Exception sending context initialized event to listener instance of class org.jboss.seam.servlet.SeamListener
      java.lang.IllegalArgumentException: no property for configuration setting: org.jboss.seam.core.init.managedPersistenceContexts
      at org.jboss.seam.Component.initInitializers(Component.java:311)
      at org.jboss.seam.Component.(Component.java:209)
      at org.jboss.seam.Component.(Component.java:159)
      at org.jboss.seam.Component.(Component.java:154)
      .....
      at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.doScan(AbstractDeploymentScanner.java:263)
      at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.loop(AbstractDeploymentScanner.java:274)
      at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.run(AbstractDeploymentScanner.java:225)
      Caused by: java.beans.IntrospectionException: Method not found: isManagedPersistenceContexts
      at java.beans.PropertyDescriptor.(PropertyDescriptor.java:89)
      at java.beans.PropertyDescriptor.(PropertyDescriptor.java:53)
      at org.jboss.seam.Component.initInitializers(Component.java:307)
      ... 98 more

      I took all the defaults, other than of course changing the datasource. I can run the seam examples ok, as I have done the latest upgrade. I'm on the newest release of Jboss IDE and hibernate tools, but I tried switching to various more recent builds but that doesn't fix it.

      The seam.properties file (which is included in the .ejb3 file) has the following entries:
      org.jboss.seam.core.init.managedPersistenceContexts entityManager
      org.jboss.seam.core.init.jndiPattern seamapp/#\{ejbName}/local

      I've also tried putting these settings in the web.xml file, but to no avail.

      I've run out of ideas... please help!

      Thx ahead of time...