1 Reply Latest reply on Jul 14, 2006 9:41 AM by Gus Gu

    For help on myfaces/tiles + fileUpload

    Gus Gu Expert

      Hi there,

      It seems I got some class loading problem on Seam. I followed Seam/wiki/fileupload instruction to add the file uploading function (which worked on JBoss, JSF/EJB3), and put the tomahawk.jar in ear file. However, when I deployed my application to JBoss 4.0.4.GA, the myfaces/tiles cannot find its struts tiles class. If I put the tomahawk.jar in WEB/lib, the org/apache/commons/fileupload/disk/DiskFileItem could not be found. I really have no idea. Any help will be very appreciated. Thank you in advance.

        • 1. Re: For help on myfaces/tiles + fileUpload
          Gus Gu Expert

          Hi All,

          It seems that I didn't install the JBoss4.0.4.GA correctly. I always got the exception of no class found on org/apache/commons/fileupload/disk/DiskFileItem. In addition, when I used conversation bean to submit a form, it didn't work. However, when I changed the conversation bean to session bean, it worked. I think that I probably selected "all" on the JBoss4.0.4.GA installation(I forgot), and did not select EJB3. I will try to reinstall it again. Thank you for time.