0 Replies Latest reply on Nov 28, 2008 6:09 AM by Raluca Jucan

    Problem generating richfaces components with apache

    Raluca Jucan Newbie

      Hi everybody

      I have the following problem. I'm using tomcat to deploy my application and everything works fine. When I access my project using ip:8080 all elements are properly generated. I'm using Apache for a forward productiv environment and when I try to access my application through www.myDomain.de the following components are not generated in Iexplorer: rich:FileUpload and rich:ModalPanel. I have errors on the page: ModalPanel not defined, FileUpload not defined.

      Here is the vhost.conf file

      LoadModule rewrite_module /usr/lib/apache2/mod_rewrite.so
      LoadModule jk_module /usr/lib/apache2/mod_jk.so
      # Declare the module for <IfModule directive> (remove this line on Apache 2.x)
      #AddModule mod_jk.c
      # Where to find workers.properties
      # Update this path to match your conf directory location (put workers.properties next to httpd.conf)
      JkWorkersFile /etc/tomcat55/workers.properties
      # Where to put jk shared memory
      # Update this path to match your local state directory or logs directory
      JkShmFile /var/log/apache2/mod_jk.shm
      # Where to put jk logs
      # Update this path to match your logs directory location (put mod_jk.log next to access_log)
      JkLogFile /var/log/apache2/mod_jk.log
      # Set the jk log level [debug/error/info]
      JkLogLevel info
      # Select the timestamp log format
      JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "


      <VirtualHost *>
      DocumentRoot /usr/share/tomcat55/webapps/Application/
      JkMount /* worker1
      # Serve html, jpg and gif using httpd
      # JkUnMount /*.html ajp13
      # JkUnMount /*.jpg ajp13
      # JkUnMount /*.gif ajp13
      ServerName www.myDomain.de
      ServerAdmin info@myDomain.de
      <Directory "/usr/share/tomcat55/webapps/Application/">
      Options Indexes MultiViews
      AllowOverride none
      Allow from all

      <Location "/WEB-INF/">
      #AllowOverride None
      deny from all

      RewriteEngine On
      Options +FollowSymlinks
      RewriteCond %{HTTP_HOST} ^myDomain\.de$ [NC]
      RewriteRule ^ http://www.myDomain.de [R,L]



      The workers.properties file looks like this:

      worker.list=worker1
      # Set properties for worker1 (ajp13)
      worker.worker1.type=ajp13
      worker.worker1.host=localhost
      worker.worker1.port=8009


      Thanks.