2 Replies Latest reply on Oct 24, 2007 10:43 AM by Shoumik Kahali

    seam application error safter deployment- ejb-jar.xml must e

    Shahruk Niazi Newbie

      seam application successfully deployed. . Here is what;s going wrong

      Build Seam by running "ant" the Seam root directory...this is successful

      Build and deploy the example by running "ant" in the Seam
      "examples/booking" directory...this is successful....

      Started JBoss AS by typing "bin/run.sh" in the JBoss home directory

      Pointed browser to:

      http://localhost:8080/seam-booking/

      and it coughs and gives me the following in the browser
      ==========

      HTTP Status 404 - /seam-booking

      --------------------------------------------------------------------------------

      type Status report

      message /seam-booking

      description The requested resource (/seam-booking) is not available.


      --------------------------------------------------------------------------------

      Apache Tomcat/5.5.17
      ===================================

      Tomcat is also started as service in bckground.

      This is from the JBOSS start.bat log.
      =====================================
      12:42:14,906 ERROR [URLDeploymentScanner] Incomplete Deployment listing:

      --- Incompletely deployed packages ---
      org.jboss.deployment.DeploymentInfo@704d3bd5 { url=file:/C:/jboss-4.0.4.GA/serve
      r/default/deploy/jboss-seam-booking.ear }
      deployer: org.jboss.deployment.EARDeployer@b31b77
      status: Deployment FAILED reason: ejb-jar.xml must either obey the right xml s
      chema or define a valid DOCTYPE!
      state: FAILED
      watch: file:/C:/jboss-4.0.4.GA/server/default/deploy/jboss-seam-booking.ear
      altDD: null
      lastDeployed: 1154454133203
      lastModified: 1154454131828
      mbeans:
      ==============================

      Anyone seen this one before, any suggesiton ? Thanks

        • 1. Re: seam application error safter deployment- ejb-jar.xml mu
          Gavin King Master

          Install JBoss using the JEMS installer and select the ejb3 profile. Please follow the "Getting Started" guide.

          • 2. Re: seam application error safter deployment- ejb-jar.xml mu
            Shoumik Kahali Newbie

            Hi,

            I was also facing similar issue...one thing I noticed was in the build.properties file I was putting following entry:
            jboss.home=C:\JBoss\jboss-4.2.2.GA

            When I was doing above a folder was getting created in my
            c:\JBoss\jboss-seam-2.0.0.CR2\examples\booking directory as:

            JBossjboss-4.2.2.GA\server\default\deploy

            so what I deed was I copied the following files:
            booking-ds.xml
            jboss-seam-booking.ear

            From
            c:\JBoss\jboss-seam-2.0.0.CR2\examples\booking\JBossjboss-4.2.2.GA\server\default\deploy

            To
            c:\JBoss\jboss-4.2.2.GA\server\default\deploy

            The JBoss took some time to recognize a new application is deployed and after some time (less than a minute) I tried to launch the application and it worked for me.....

            If you dont want to all the above step, After exploring more I came to know there is a quicker/easier way check your build.properties file and see the following entry,(escaped '\' character)

            jboss.home=D:\\JBoss\\jboss-4.2.2.GA

            When I used the above configuration and call ant build command
            I deploys the example application directly to the JBoss Application Server path:
            c:\JBoss\jboss-4.2.2.GA\server\default\deploy

            Try this I hope this might help to resolve your issue.

            Regards
            Shoumik