3 Replies Latest reply on Dec 3, 2008 9:21 AM by Tatyana Romanovich

    modal panel does not show up

    hemant mahidhara Newbie

      modal panel does not come up. instead i see a white area where the modal panel was supposed to show up and i see a small (about 5px by 5px) button on the top left corner of the page.

      modal panel was working for me all this time, all of a sudden this behaviour has started occuring. now all modal panels in my app are behaving the same way.

      I have not changed anything in my environment, all i was doing was working on the layout of a modal panel.

      please help

        • 1. Re: modal panel does not show up
          Nick Belaevski Master

          Hello,

          Please add the following information:

          1. RF version
          2. Browser version
          3. Page code

          • 2. Re: modal panel does not show up
            hemant mahidhara Newbie

            Here is the information; The strange thing is that all this was working before and suddenly stopped working; also it continues to work on my coleagues machine but does not work for anybody else.

            RF Version = 3.2.2

            Browser = ie 6.0.2

            Page Code: test.jsp

            <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
            <html>
            <%@ taglib uri="http://java.sun.com/jsf/core" prefix="f"%>
            <%@ taglib uri="http://java.sun.com/jsf/html" prefix="h"%>
            <%@ taglib uri="http://richfaces.ajax4jsf.org/rich" prefix="rich"%>
            
            <f:view>
            <body>
             <h:outputLink
             onclick="javascript:Richfaces.showModalPanel('panel');return false">
             Test Modal
             </h:outputLink>
             <c:import url="testModal.jsp" />
            </body>
            </f:view>
            </html>
            


            Page Code: testModal.jsp
            <%@ taglib uri="http://java.sun.com/jsf/core" prefix="f"%>
            <%@ taglib uri="http://java.sun.com/jsf/html" prefix="h"%>
            <%@ taglib uri="http://richfaces.ajax4jsf.org/rich" prefix="rich"%>
            
            <rich:modalPanel id="panel" width="350" height="100">
             <f:facet name="header">
             <h:panelGroup>
             <h:outputText value="Modal Panel"></h:outputText>
             </h:panelGroup>
             </f:facet>
             <f:facet name="controls">
             <h:panelGroup>
             <h:graphicImage value="/images/modal/close.png" style="cursor:pointer" id="hidelink"/>
             <rich:componentControl for="panel" attachTo="hidelink" operation="hide" event="onclick"/>
             </h:panelGroup>
             </f:facet>
             <h:outputText value="Hello World"></h:outputText>
            </rich:modalPanel>
            


            • 3. Re: modal panel does not show up
              Tatyana Romanovich Newbie

              Hello, hemantmahidhara!
              I've been tried to reproduce that failure, but my app (with rf-3.2.2.GA) works fine: modal panel with text and icon is displayed correctly in the IE6.0.2900

              So, could you create test project and provide link or send me ready to run on server WAR file with all needed libs, please?