8 Replies Latest reply on Nov 11, 2006 12:11 AM by Ramiro Guerrero

    Problems deploying my CRUD app generated by Hibernate Tools

    Ramiro Guerrero Newbie

      Hi everyone,

      I would be very pleased if somebody can give me some support about this simple task. I ran the Reverse Engineering tool provided by Hibernate Tools Eclipse plugin to generate a complete JBOSS CRUD App. I followed all the instructions provided by the file README.TXT included in the generated app.
      The tool generated an .ear file (seamapp.ear). Now I am running my JBOSS AS; and a part of this .ear(seamapp.ejb3) failed to be deployed. Only the .war part of this .ear was successfully deployed.

      I can only tell you when the tool generated the .java sources, the class javax.ejb3.Interceptors did not exist; so I had to replace all those imports by javax.interceptor.Interceptors which did really exist (I have included all the .jars included in the README.txt file) . There were no more generation errors during the build process.

      Another thing It could be wrong ....
      I also copied all those .jars into my C:\jboss-4.0.4.GA\server\default\lib
      Those .jars are:
      jboss-seam.jar, jboss-ejb3x.jar, ejb3-persistence.jar, myfaces-api.jar, jboss-annotations-ejb3.jar, hibernate-annotations.jar to the lib/ directory

      Does anyone know if another .jar is necessary?

      My Jboss AS installation is full (it has all the features)

      Here you have the JBOSS CRUD APP generation instructions:

      Instructions
      ------------
      (1) Copy jboss-seam.jar, jboss-ejb3x.jar, ejb3-persistence.jar, myfaces-api.jar, jboss-annotations-ejb3.jar, hibernate-annotations.jar to the lib/ directory
      (2) Edit build.properties to point to your JBoss 4.0.4 home directory
      (3) Run build.xml using Ant
      (4) Start JBoss from Eclipse or command line
      (5) Go to http://localhost:8080/seamapp


      thanks,
      regards
      Ramiro Guerrero