2 Replies Latest reply on Dec 10, 2008 11:39 AM by Ker P

    Richfaces 3.2.2 on WAS 7.0

    Ker P Newbie

      Hi !

      In our company, we developed a small web application with Richfaces 3.2.2 , running on Tomcat 6.0.18 .
      Our development environment is Rational Application Developer 7.5 . Currently, we are trying to get this application running on WAS 7.0 (with latest fixpack) , and we run into troubles.

      Each time we start our application, we get this :

      10/12/08 14:20:30:526 CET 0000000a config I Initializing Sun's JavaServer Faces implementation (1.2_07-b03-FCS) for context '/Depairon'
      10/12/08 14:20:34:216 CET 0000000a FfdcProvider I com.ibm.ws.ffdc.impl.FfdcProvider logIncident FFDC1003I: FFDC Incident emitted on C:\Program Files\IBM\SDP\runtimes\base_v7\profiles\AppSrv01\logs\ffdc\server1_372e372e_08. 12.10_14.20.34.0767222673105519956264.txt com.ibm.ws.webcontainer.webapp.WebApp.notifyServletContextCreated 1341
      10/12/08 14:20:34:247 CET 0000000a webapp E com.ibm.ws.webcontainer.webapp.WebApp notifyServletContextCreated SRVE0283E: Exception interceptée lors de l''initialisation du contexte : {0}
      java.lang.NoSuchMethodError: com/sun/faces/config/GlassFishConfigureListener.scanWebXml(Z)V
      + at com.sun.faces.config.GlassFishConfigureListener.contextInitialized(GlassFishCon figureListener.java:46)+
      + at com.ibm.ws.webcontainer.webapp.WebApp.notifyServletContextCreated(WebApp.java:1 588)+
      + at com.ibm.ws.webcontainer.webapp.WebApp.commonInitializationFinish(WebApp.java:35 0)+
      + at com.ibm.ws.webcontainer.webapp.WebAppImpl.initialize(WebAppImpl.java:292)+
      + at com.ibm.ws.webcontainer.webapp.WebGroupImpl.addWebApplication(WebGroupImpl.java :99)+
      + at com.ibm.ws.webcontainer.VirtualHostImpl.addWebApplication(VirtualHostImpl.java: 167)+
      + at com.ibm.ws.webcontainer.WSWebContainer.addWebApp(WSWebContainer.java:727)+
      + at com.ibm.ws.webcontainer.WSWebContainer.addWebApplication(WSWebContainer.java:61 2)+
      + at com.ibm.ws.webcontainer.component.WebContainerImpl.install(WebContainerImpl.jav a:376)+
      + at com.ibm.ws.webcontainer.component.WebContainerImpl.start(WebContainerImpl.java: 668)+
      + at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:1 142)+
      + at com.ibm.ws.runtime.component.DeployedApplicationImpl.fireDeployedObjectStart(De ployedApplicationImpl.java:1313)+
      + at com.ibm.ws.runtime.component.DeployedModuleImpl.start(DeployedModuleImpl.java:6 11)+
      + at com.ibm.ws.runtime.component.DeployedApplicationImpl.start(DeployedApplicationI mpl.java:938)+
      + at com.ibm.ws.runtime.component.ApplicationMgrImpl.startApplication(ApplicationMgr Impl.java:721)+
      + at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:2 062)+
      + at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.start(CompositionUnitMgrImp l.java:437)+
      + at com.ibm.ws.runtime.component.CompositionUnitImpl.start(CompositionUnitImpl.java :122)+
      + at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.start(CompositionUnitMgrImp l.java:380)+
      + at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.access$300(CompositionUnitM grImpl.java:108)+
      + at com.ibm.ws.runtime.component.CompositionUnitMgrImpl$CUInitializer.run(Compositi onUnitMgrImpl.java:935)+
      + at com.ibm.wsspi.runtime.component.WsComponentImpl$_AsynchInitializer.run(WsCompon entImpl.java:349)+
      + at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1527)+


      followed at the end by :

      10/12/08 14:20:52:218 CET 00000016 CacheManager I org.ajax4jsf.cache.CacheManager getCacheFactory Selected http://org.ajax4jsf.cache.L RUMapCacheFactory cache factory


      and then a thread seems to be hung.

      The web.xml looks like this :



      "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
      "http://java.sun.com/dtd/web-app_2_3.dtd">
      
      
      + +
      + com.sun.faces.validateXml+
      + true+
      + +
      + +
      + +
      + +
      org.richfaces.SKIN
      ruby
      
      
      richfaces
      org.ajax4jsf.Filter
      
      
      richfaces
      Faces Servlet
      
      
      
      + +
      + Faces Servlet+
      + javax.faces.webapp.FacesServlet+
      + 1+
      + +
      + +
      + Faces Servlet+
      + *.faces+
      + +
      + +
      + +
      + index.htm+
      + +


      and here are the jars we use :

      antlr-2.7.6.jar
      asm.jar
      cglib-2.1.3.jar
      common-annotations.jar
      commons-beanutils.jar
      commons-collections.jar
      commons-digester.jar
      commons-io-1.4.jar
      commons-logging.jar
      dom4j-1.6.1.jar
      hibernate-annotations.jar
      hibernate-validator.jar
      hibernate3.jar
      jsf-api.jar
      jsf-impl.jar
      jstl-1.2.jar
      jta-1.0.1B.jar
      richfaces-api-3.2.2.GA.jar
      richfaces-impl-3.2.2.GA.jar
      richfaces-ui-3.2.2.GA.jar

      Anybody got richfaces 3.2.2 running on WAS 7.0 ?

      Best Regards,