5 Replies Latest reply on Feb 8, 2007 1:45 PM by Gavin King

    Seam no longer compatible with facelets 1.0.14?

    Andrew Apprentice

      I just tried to upgrade Seam from 1.1.0 to 1.1.6 and I can no longer deploy our EAR/WAR. We are running facelets 1.0.14 and cannot switch to 1.1.x at this time due to compatibility breaking changes in 1.1.x. Seam is now throwing:

      10:44:47,253 ERROR [[/OSoft]] Exception sending context initialized event to listener instance of class org.jboss.seam.servlet.SeamListener
      java.lang.NoClassDefFoundError: com/sun/facelets/impl/ResourceResolver
       at java.lang.Class.getDeclaredMethods0(Native Method)
       at java.lang.Class.privateGetDeclaredMethods(Class.java:2395)
       at java.lang.Class.getDeclaredMethods(Class.java:1763)
       at org.jboss.seam.Component.initMembers(Component.java:436)
       at org.jboss.seam.Component.<init>(Component.java:256)
       at org.jboss.seam.Component.<init>(Component.java:207)
       at org.jboss.seam.init.Initialization.addComponent(Initialization.java:781)
       at org.jboss.seam.init.Initialization.addComponents(Initialization.java:690)
       at org.jboss.seam.init.Initialization.init(Initialization.java:451)
       at org.jboss.seam.servlet.SeamListener.contextInitialized(SeamListener.java:33)
      ...


      It looks like there was an undocumented compatibility breaking change in Seam of requiring 1.1.x of facelets. Is this true? If so, what is the latest version of Seam that can run on facelets 1.0.x? Also, is there any way to find out these types of non-backwards compatible changes in Seam releases (it was not in the release notes that I saw)?

      Also would it be possible to fix this in 1.1.7 so that only facelets 1.0.x is required instead of 1.1? 1.0.14 is considered a stable production facelets release and IMO should be supported if possible.

      Thank you