4 Replies Latest reply on Feb 26, 2007 9:22 AM by Mariusz Smykula

    Unable to authenticate in 1.1.7RC1 : is it a regression?

    Alex Kozlenkov Newbie

      Hi,

      My previously working code is no longer functional in 1.1.7RC1. A fragment of the stack trace is given below

      Caused by: java.lang.NoSuchMethodError: org.jboss.seam.security.Identity.addRole(Ljava/lang/String;)V
       at LoginAction.authenticate(LoginAction.java:70)
       at LoginAction$$FastClassByCGLIB$$92230edf.invoke(<generated>)
       at net.sf.cglib.proxy.MethodProxy.invoke(MethodProxy.java:149)
       at org.jboss.seam.intercept.RootInvocationContext.proceed(RootInvocationContext.java:45)
       at org.jboss.seam.intercept.SeamInvocationContext.proceed(SeamInvocationContext.java:57)
       at org.jboss.seam.interceptors.RollbackInterceptor.aroundInvoke(RollbackInterceptor.java:34)
       at org.jboss.seam.intercept.SeamInvocationContext.proceed(SeamInvocationContext.java:69)
       at org.jboss.seam.interceptors.BijectionInterceptor.aroundInvoke(BijectionInterceptor.java:47)


      I've verified that I am packaging the latest RC1 from the CVS repository. Any ideas about this behaviour?

      Cheers--Alex