5 Replies Latest reply on Dec 29, 2008 3:49 PM by Mark LoSacco

    Problem with Seam <s:link> with RichFaces using Safari

    Mark LoSacco Newbie

      We are having a problem on Safari with Seam link and button tags in combination with f:param. Basically code such as shown below:

      <rich:column
       sortBy="#{_player.user.userLname}"
       sortOrder="ASCENDING">
       <f:facet name="header">
       #{messages['com.leagueunited.admin.member.name']}
       </f:facet>
       <s:link value="#{_player.user.userFname} #{_player.user.userLname}"
       title="#{messages['com.leagueunited.btn.edit']}"
       view="/manager/member.xhtml">
       <f:param name="userId" value="#{_player.user.userId}" />
       <f:param name="from" value="league" />
       <f:param name="selectTab" value="teams" />
       </s:link>
      </rich:column>
      


      after redirect in Safari results in URL such as (please ignore backslash character used to escape # for purpose of posting):


      http://localhost:8080/lu/manager/member.seam?userId=1143&\#38;from=league&%2338;selectTab=teams&%2338;sportId=4&%2338;teamId=45&%2338;cid=68


      instead of:


      http://localhost:8080/lu/manager/member.seam?userId=1143&from=league&selectTab=teams&sportId=4&teamId=45&cid=68


      Basically it is encoding the first & to &\#38; (again, minus the backslash character), and subsequent &'s to &%2338;

      Same code works fine in both IE and Firefox.

      Others have posted about this problem to the Seam forum here:
      http://www.seamframework.org/Community/ProblemWithSlinkInCombinationWithRichFacesUsingSafari#comment56666


      -Mark