3 Replies Latest reply on May 28, 2007 3:35 PM by Arjan van Bentem

    Should Seam 1.3 (CVS) run on Java 6?

    Arjan van Bentem Novice

      I wonder if Seam 1.3 (currently only in CVS) is supposed to be able to run in Java 6?

      If so, then I'll report issues I find (such as a "[SOAPFaultHelperJAXWS] SOAP request exception java.lang.UnsupportedOperationException: setProperty must be overridden by all subclasses of SOAPMessage" that I seem to get in the SeamBay example in JDK 1.6, but not in 1.5).

      I've seen few posts for older versions:

      Building Seam CVS with ant build
      The main problems that I have encountered are that JBoss unfortunately includes many JARs for packages that are now part of the Java 6 distribution.

      SEAM INSTALLATION
      Use JDK 5.0.

        • 1. Re: Should Seam 1.3 (CVS) run on Java 6?
          Arjan van Bentem Novice

           

          "avbentem" wrote:
          If so, then I'll report issues I find (such as a "<i>[SOAPFaultHelperJAXWS] SOAP request exception java.lang.UnsupportedOperationException: setProperty must be overridden by all subclasses of SOAPMessage</i>" that I seem to get in the SeamBay example in JDK 1.6, but not in 1.5).

          This is in fact a known issue in JBossWS (JBoss AS 4.2.0.GA ships with jbossws-1.2.1.GA). A comment at JBWS-1439 claims "The reason for this is the SAAJ classes being used in Sun JDK 1.6.0 are not compatible with JBossWS since they use their own SAAJ jar named jboss-saaj.jar".

          So, apart from web services: should we report Java 6 specific errors for Seam 1.3 -- if one encounters one?

          Arjan.

          • 2. Re: Should Seam 1.3 (CVS) run on Java 6?
            Gavin King Master

            If its a known issue in JBossWS, there is absolutely no reason to report it as a seam issue.

            • 3. Re: Should Seam 1.3 (CVS) run on Java 6?
              Arjan van Bentem Novice

               

              "avbentem" wrote:
              So, apart from web services: should we report Java 6 specific errors for Seam 1.3 -- if one encounters one?
              "gavin.king@jboss.com" wrote:
              If its a known issue in JBossWS, there is absolutely no reason to report it as a seam issue.


              Of course. And maybe I shouldn't ask before actually running into any Seam specific Java 6 issue (especially as I'll probably stick to Java 5 to avoid the JBossWS problems). But I just wondered if Seam 1.3 is supposed to run in Java 6.

              Thanks,
              Arjan.