3 Replies Latest reply on May 29, 2007 9:48 AM by Fernando Montaño

    stupid question about message "Welcome" of seam security

    Mohammad Norouzi Novice

      Hi

      When I log in using seam Authenticator, a message "Welcome user_name" will be displayed

      I can't find that message in any resource bundle. I want to display another message with related language that user specified how can I remove that message :))

      I am using Seam v1.1.6
      thanks

        • 1. Re: stupid question about message
          Mateusz Mrozewski Newbie

          I think it's:
          project_name/resources/messages_en.properties

          • 2. Re: stupid question about message
            Mohammad Norouzi Novice

            No I have Messages.properties under the specific path

            com.mypackage.bundle.Messages.properites

            but the problem is it can't understand it

            this is from Seam tutorial:

            You can select a different name for the resource bundle by setting the Seam configuration property named
            org.jboss.seam.core.resourceBundle.bundleNames. You can even specify a list of resource bundle names
            to be searched (depth first) for messages.
            <core:resource-bundle>
            <core:bundle-names>
            <value>mycompany_messages</value>
            <value>standard_messages</value>
            </core:bundle-names>
            </core:resource-bundle>
            
            


            • 3. Re: stupid question about message
              Fernando Montaño Expert

               

              "mnrz" wrote:
              Hi

              When I log in using seam Authenticator, a message "Welcome user_name" will be displayed

              I can't find that message in any resource bundle. I want to display another message with related language that user specified how can I remove that message :))

              I am using Seam v1.1.6
              thanks



              Seam adds a default message for this kind of stuff. Of course if you don't like this you can override as follows in your messages.properties:
              a) No message after login:
              org.jboss.seam.loginSuccessful
              

              b) As you like message:
              org.jboss.seam.loginSuccessful = Welcome, #0
              


              HTH.