0 Replies Latest reply on Jun 10, 2007 9:51 AM by Martin Kuhn

    componens.xml - problem with spring context and resource bun

    Martin Kuhn Newbie

      Hi,

      I tried to start a Spring ApplicationContext via components.xml.
      (I use Seam 1.2.1). But the loading of the Spring configuration files don't take place.
      There is no output in the log when I switched the log4j config to debug for package org.jboss.seam.

      BTW: Furthermore, it's also not possible to define additional resource bundles like in the example. I've to use the standard JSF way with <f:loadBundle .... />

      Here is a part of my components.xml

      <?xml version="1.0" encoding="UTF-8"?>
      <components xmlns="http://jboss.com/products/seam/components"
       xmlns:core="http://jboss.com/products/seam/core"
       xmlns:spring="http://jboss.com/products/seam/spring"
       xmlns:drools="http://jboss.com/products/seam/drools"
       xmlns:security="http://jboss.com/products/seam/security"
       xmlns:web="http://jboss.com/products/seam/web"
       xmlns:mail="http://jboss.com/products/seam/mail"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xsi:schemaLocation=
       "http://jboss.com/products/seam/core http://jboss.com/products/seam/core-1.2.xsd
       http://jboss.com/products/seam/drools http://jboss.com/products/seam/drools-1.2.xsd
       http://jboss.com/products/seam/security http://jboss.com/products/seam/security-1.2.xsd
       http://jboss.com/products/seam/spring http://jboss.com/products/seam/spring-1.2.xsd
       http://jboss.com/products/seam/web http://jboss.com/products/seam/web-1.2.xsd
       http://jboss.com/products/seam/mail http://jboss.com/products/seam/mail-1.2.xsd
       http://jboss.com/products/seam/components http://jboss.com/products/seam/components-1.2.xsd">
      
       <core:init debug="true" jndi-pattern="#{ejbName}/local"/>
      
       <spring:context-loader>
       <spring:config-locations>
       <value>/appDbContext.xml</value>
       <value>/appContext.xml</value>
       <value>/appDaoContext.xml</value>
       <value>/appServiceContext.xml</value>
       </spring:config-locations>
       </spring:context-loader>
      
       <core:resource-bundle>
       <core:bundle-names>
       <value>app_labels</value>
       <value>app_messages</value>
       <value>messages</value>
       </core:bundle-names>
       </core:resource-bundle>
       ....
      
      


      Could anybody give me a hint what's wrong.

      TIA