1 Reply Latest reply on Jun 18, 2007 7:23 AM by Jaime Martin

    mapping problems

    Jaime Martin Apprentice

      hello,
      I´m testing files generated by means of seam-gen. When I run the seam app there is this error:

      An Error Occurred:
      /RstReportList.xhtml @39,62 rendered="#{empty myPOJO.resultList}": Exception getting value of property resultList of base of type : action.package.MyPOJO _$$_javassist_11

      In the log:
      Caused by: org.hibernate.hql.ast.QuerySyntaxException: MyPOJO is not mapped [select myPOJO from MyPOJO myPOJO]

      It seems that there is some configuration problem. The content of the persistence.xml file is the following: (I´m using Sybase and my database schema is dbo)

      <?xml version="1.0" encoding="UTF-8"?>
      <!-- Persistence deployment descriptor for dev profile -->
      <persistence xmlns="http://java.sun.com/xml/ns/persistence"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xsi:schemaLocation="http://java.sun.com/xml/ns/persistence http://java.sun.com/xml/ns/persistence/persistence_1_0.xsd"
       version="1.0">
      
       <persistence-unit name="ONLINE" transaction-type="JTA">
       <provider>org.hibernate.ejb.HibernatePersistence</provider>
       <jta-data-source>java:/ONLINEDatasource</jta-data-source>
       <properties>
       <property name="hibernate.hbm2ddl.auto" value="update"/>
       <property name="hibernate.show_sql" value="true"/>
       <property name="hibernate.transaction.manager_lookup_class" value="org.hibernate.transaction.JBossTransactionManagerLookup"/>
       <property name="hibernate.dialect" value="org.hibernate.dialect.SybaseDialect"/>
       <property name="hibernate.default_schema" value="dbo"/>
       <property name="jboss.entity.manager.factory.jndi.name" value="java:/ONLINEEntityManagerFactory"/>
       </properties>
       </persistence-unit>
      
      </persistence>
      
      
      


      Any idea will be welcomed.
      thanks in advance!



        • 1. Re: mapping problems
          Jaime Martin Apprentice

          I´ve realised that seam-gen hasn´t created a hibernate.cfg.xml. I´ve done it but the same error goes on. I´m not sure if that hibernate.cfg file is being readed.
          I have started with a database, and with seam-gen I´ve generated the pojos and views. The error happens when invoking the view because the pojos are not properly mapped.
          Any config suggestions?
          thank you!