3 Replies Latest reply on Jul 21, 2007 7:27 PM by fhh

    compüonents.xml not scanned on Linux...

    fhh Expert

      I have a strange problem: On my development machine running windows my application work fine. When I deploy it to the server it fails because the components.xml file is not scanned properly.

      The odd thing is that components.xml is found:

      2007-07-19 00:09:10,785 DEBUG [org.jboss.seam.deployment.Scanner] archive: /opt/jboss-4.2.0.GA/server/default/tmp/deploy/tmp42377go100-backoffice.ear-contents/go100-model-ejb-0.1-SNAPSHOT.jar
      ...
      2007-07-19 00:09:10,785 DEBUG [org.jboss.seam.deployment.Scanner] found: META-INF/components.xml
      


      The only hint I have is the following warning during deployment:

      2007-07-19 00:09:10,905 WARN [org.jboss.seam.init.Initialization] namespace declared in components.xml does not resolve to a package annotated @Namespace: http://jboss.com/products/seam/persistence
      


      My compnents.xml looks like this:
      <components xmlns="http://jboss.com/products/seam/components"
       xmlns:persistence="http://jboss.com/products/seam/persistence"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xsi:schemaLocation="http://jboss.com/products/seam/persistence http://jboss.com/products/seam/persistence-2.0.xsd">
      
      
      
      
       <persistence:managed-persistence-context name="entityManager"
       auto-create="true"
       persistence-unit-jndi-name="java:/EntityManagerFactories/go100" />
      
      
      </components>


      Does anybody know why this might work under Windows and not under Linux? My first suspicion that this might be about the upper/lower case.

      Regards

      Felix