0 Replies Latest reply on Jul 24, 2007 7:58 AM by Sean Burns

    Validation not working after upgrade

    Sean Burns Newbie

      Hi,

      I have just upgraded from JBoss 4.0.5 to 4.2.1, and at the same time upgraded to Seam 2 from 1.2.1.

      Everything is working fine except the hibernate validations, which don't seem to be working at all.

      This is my setup that was working with Seam 1.2.1

      <s:decorate id="contactNoDecoration" template="layout/edit2.xhtml">
       <h:inputText id="contactNo" required="true"
       value="#{CaptureLead.contactNo}" class="input"
       style="width:100%">
       <a:support event="onblur" reRender="contactNoDecoration" />
       </h:inputText>
      </s:decorate>


      and my edit2.xhtml is

      <ui:composition xmlns="http://www.w3.org/1999/xhtml"
       xmlns:ui="http://java.sun.com/jsf/facelets"
       xmlns:h="http://java.sun.com/jsf/html"
       xmlns:f="http://java.sun.com/jsf/core"
       xmlns:s="http://jboss.com/products/seam/taglib">
      
      
       <span class="value #{invalid?'errors':''}"> <s:validateAll>
       <ui:insert />
       </s:validateAll> </span>
       <s:message styleClass="error errors" />
      
      
      </ui:composition>


      and

      @Pattern(regex = "[0-9]{10}", message = "{validator.form.contactNo}")
       public String getContactNo() {
       return contactNo;
       }


      This validation is no longer happening with the onblur (the required=true does work though).... I had a look at the seam doc and the only new thing I could see was bypassUpdates="true". I added this with no luck.

      Is there some configuration step that I have missed?


      Thanks,
      Sean.