3 Replies Latest reply on Jul 25, 2007 3:53 PM by Gavin King

    Is org.jboss.logging.Logger in JBoss 4.2.1 compatible with S

    Tony Mai Apprentice

      Hello all,

      I am running into weird logger incompatible version after upgrading my JBoss AS to JBoss 4.2.1GA (from 4.0.5GA). I am still using Seam 1.2.1GA. No change in my code.

      Yet my client is now complaining that it could not perform a Context.lookup(). It threw an exception at:

      java.lang.NoSuchFieldError: TRACE
      at org.jboss.logging.Log4jLoggerPlugin.isTraceEnabled(Log4jLoggerPlugin.java:85)
      at org.jboss.logging.Logger.isTraceEnabled(Logger.java:122)
      at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:620)


      So somewhere in the server/client, a wrong version of Logger is being used and I don't know which component is loading this Logger in the first place.

      Has anyone here run into this problem or know how to fix this. I would appreciate a comment.

      Thanks
      -tony