1 Reply Latest reply on Aug 9, 2007 4:21 PM by norman.richards

    The need for "()" in from-action

      I was a little bit confused on whether you need to include the "()" in a from-action in the pages.xml all the time or some of the time, or only on days that start with a "W"

      Looking in what I currently have for pages.xml it appears that it isn't necessary to have "()". However, in one particular case it was specifically that I didn't have the "()" that it was failing.

      In the Pages.java code it would mean that it must have the "()" In order to find the action in the stored Map.

      So I guess the best way is to always include "()" in your from-action. :)


        • 1. Re: The need for

          That is a new notation in JBoss EL. For an action, it should make no difference to use #{bean.foo} or #{bean.foo()}. If there were a difference, I'd call it a bug. It does make a BIG difference when it comes to values, but not actions.