3 Replies Latest reply on Sep 13, 2007 3:46 PM by Humber

    Seam deployment problem

    Jiang Liu Newbie

      Hi gurus,
      I am using AS 4.2.1 and Seam 2.0beta.

      I have deployed one stateless action manager named, for example, abc. For some reasons i have to rename it to abcd and made some modifications. Now when i re-deploy the project, the concle throws exceptions state that "Two components with the same name and precedence".

      I have tried physically delete (at both AS folder and eclipse folder) deployed project and re-deploy, problem remains.

      The only solution now that i can do is to provide a different name for the abcd component, and it deploys. So could anyone tell me how to fix this problem?

      Thanks in advance!

        • 1. Re: Seam deployment problem
          matt zaber Newbie

          have you tried project => clean in eclipse?

          also, when i was trying to convert a seam-gen proj to an eclipse ear i had both projects open and autobuilding, so the ant deploy from seamgen and hot deploy from eclipse were installing compopnents of the same name and giving this error (doh) maybe something to check

          if all else fails, maybe try cleaning the relevant work/ and tmp/ entries as well as deploy/ stuff.

          /matt

          • 2. Re: Seam deployment problem
            Daniel Kane Novice

            The same problem but with Seam 1.2.1GA . Tried Project..Clean in Eclipse, no effect. Restarted JBoss, Eclipse, emoved files manually - no way.

            • 3. Re: Seam deployment problem
              Humber Newbie

              Try this:

              1) Shutdown your JBoss AS 4.0.5.GA
              2) Delete the folder server/default/tmp/ . It contains deployment info and some times creates conflict with entities.
              3) Go to your project folder and run:
              ant clean
              4) Run
              ant undeploy
              5) Then do the deploy(wit hthe profile you need)
              ant deploy
              6) Then start the jboss AS.

              This works for me when i have problems with diferent versions of the same Component.