6 Replies Latest reply on Oct 5, 2007 7:29 AM by Damian Harvey

    seam-gen setup and maven

    Pierre Raoul Novice

      I just updated seam from cvs and tried to created a new project.

      When I run "seam setup" I get:


      Buildfile: C:\DEV\projects\eclipse\workspace\seam-cvs\seam-gen\build.xml

      init:
      [artifact:dependencies] Downloading: org/jboss/seam/jboss-seam-gen/${version}.${patchlevel}/jboss-seam-gen-${version}.${
      patchlevel}.pom
      [artifact:dependencies] [WARNING] POM for 'org.jboss.seam:jboss-seam-gen:pom:${version}.${patchlevel}:compile' is invali
      d. It will be ignored for artifact resolution. Reason: The POM expression: ${version} could not be evaluated. Reason: Ex
      pression value '${version}.${patchlevel}' references itself in 'org.jboss.seam:jboss-seam-gen:pom:${version}.${patchleve
      l}'. for project org.jboss.seam:jboss-seam-gen at Artifact [org.jboss.seam:jboss-seam-gen:pom:${version}.${patchlevel}:c
      ompile]
      [artifact:dependencies] Downloading: org/jboss/seam/jboss-seam-gen/${version}.${patchlevel}/jboss-seam-gen-${version}.${
      patchlevel}.jar
      [artifact:dependencies] An error has occurred while processing the Maven artifact tasks.
      [artifact:dependencies] Diagnosis:
      [artifact:dependencies]
      [artifact:dependencies] Unable to resolve artifact: Missing:
      [artifact:dependencies] ----------
      [artifact:dependencies] 1) org.jboss.seam:jboss-seam-gen:jar:${version}.${patchlevel}
      [artifact:dependencies]
      [artifact:dependencies] Try downloading the file manually from the project website.
      [artifact:dependencies]
      [artifact:dependencies] Then, install it using the command:
      [artifact:dependencies] mvn install:install-file -DgroupId=org.jboss.seam -DartifactId=jboss-seam-gen \
      [artifact:dependencies] -Dversion=${version}.${patchlevel} -Dpackaging=jar -Dfile=/path/to/file
      [artifact:dependencies] Alternatively, if you host your own repository you can deploy the file there: mvn deploy:d
      eploy-file -DgroupId=org.jboss.seam -DartifactId=jboss-seam-gen \
      [artifact:dependencies] -Dversion=${version}.${patchlevel} -Dpackaging=jar -Dfile=/path/to/file \
      [artifact:dependencies] -Durl=[url] -DrepositoryId=[id]
      [artifact:dependencies]
      [artifact:dependencies] Path to dependency:
      [artifact:dependencies] 1) unspecified:unspecified:jar:0.0
      [artifact:dependencies] 2) org.jboss.seam:jboss-seam-gen:jar:${version}.${patchlevel}
      [artifact:dependencies]
      [artifact:dependencies] ----------
      [artifact:dependencies] 1 required artifact is missing.
      [artifact:dependencies]
      [artifact:dependencies] for artifact:
      [artifact:dependencies] unspecified:unspecified:jar:0.0
      [artifact:dependencies]
      [artifact:dependencies] from the specified remote repositories:
      [artifact:dependencies] central (http://repo1.maven.org/maven2)
      [artifact:dependencies]
      [artifact:dependencies]

      BUILD FAILED
      C:\DEV\projects\eclipse\workspace\seam-cvs\seam-gen\build.xml:25: Unable to resolve artifact: Missing:
      ----------
      1) org.jboss.seam:jboss-seam-gen:jar:${version}.${patchlevel}

      Try downloading the file manually from the project website.

      Then, install it using the command:
      mvn install:install-file -DgroupId=org.jboss.seam -DartifactId=jboss-seam-gen \
      -Dversion=${version}.${patchlevel} -Dpackaging=jar -Dfile=/path/to/file
      Alternatively, if you host your own repository you can deploy the file there: mvn deploy:deploy-file -DgroupId=org
      .jboss.seam -DartifactId=jboss-seam-gen \
      -Dversion=${version}.${patchlevel} -Dpackaging=jar -Dfile=/path/to/file \
      -Durl=[url] -DrepositoryId=[id]

      Path to dependency:
      1) unspecified:unspecified:jar:0.0
      2) org.jboss.seam:jboss-seam-gen:jar:${version}.${patchlevel}

      ----------
      1 required artifact is missing.

      for artifact:
      unspecified:unspecified:jar:0.0

      from the specified remote repositories:
      central (http://repo1.maven.org/maven2)


      Total time: 2 seconds



      I don't know Maven. It seams that version and patchlevel should be initialized.

      Am'I right? If so, where this must be done?


        • 1. Re: seam-gen setup and maven
          Pete Muir Master

          (Hopefully) fixed in CVS. Please try and post back if it is still problematic.

          • 2. Re: seam-gen setup and maven
            Matt Drees Master

            Hi Pete,
            Earlier I had the same problem that atao had. I just now updated from cvs and am getting new (but similar) error message.


            C:\work-exadel\jboss-seam>seam setup
            Buildfile: C:\work-exadel\jboss-seam\seam-gen\build.xml

            init:
            [artifact:dependencies] Downloading: org/jboss/seam/jboss-seam-gen/${DSTAMP}.${TSTAMP}/jboss-seam-gen-${DSTAMP}.${TSTAMP}.pom
            [artifact:dependencies] Downloading: org/jboss/seam/jboss-seam-gen/${DSTAMP}.${TSTAMP}/jboss-seam-gen-${DSTAMP}.${TSTAMP}.jar
            [artifact:dependencies] An error has occurred while processing the Maven artifact tasks.
            [artifact:dependencies] Diagnosis:
            [artifact:dependencies]
            [artifact:dependencies] Unable to resolve artifact: Missing:
            [artifact:dependencies] ----------
            [artifact:dependencies] 1) org.jboss.seam:jboss-seam-gen:jar:${DSTAMP}.${TSTAMP}
            [artifact:dependencies]
            [artifact:dependencies] Try downloading the file manually from the project website.
            [artifact:dependencies]
            [artifact:dependencies] Then, install it using the command:
            [artifact:dependencies] mvn install:install-file -DgroupId=org.jboss.seam -DartifactId=jboss-seam-gen \
            [artifact:dependencies] -Dversion=${DSTAMP}.${TSTAMP} -Dpackaging=jar -Dfile=/path/to/file
            [artifact:dependencies] Alternatively, if you host your own repository you can deploy the file there: mvn deploy:deploy-file -DgroupId=org.jboss.seam -Dar
            tifactId=jboss-seam-gen \
            [artifact:dependencies] -Dversion=${DSTAMP}.${TSTAMP} -Dpackaging=jar -Dfile=/path/to/file \
            [artifact:dependencies] -Durl=[url] -DrepositoryId=[id]
            [artifact:dependencies]
            [artifact:dependencies] Path to dependency:
            [artifact:dependencies] 1) unspecified:unspecified:jar:0.0
            [artifact:dependencies] 2) org.jboss.seam:jboss-seam-gen:jar:${DSTAMP}.${TSTAMP}
            [artifact:dependencies]
            [artifact:dependencies] ----------
            [artifact:dependencies] 1 required artifact is missing.
            [artifact:dependencies]
            [artifact:dependencies] for artifact:
            [artifact:dependencies] unspecified:unspecified:jar:0.0
            [artifact:dependencies]
            [artifact:dependencies] from the specified remote repositories:
            [artifact:dependencies] central (http://repo1.maven.org/maven2)
            [artifact:dependencies]
            [artifact:dependencies]

            BUILD FAILED
            C:\work-exadel\jboss-seam\seam-gen\build.xml:19: Unable to resolve artifact: Missing:
            ----------
            1) org.jboss.seam:jboss-seam-gen:jar:${DSTAMP}.${TSTAMP}

            Try downloading the file manually from the project website.

            Then, install it using the command:
            mvn install:install-file -DgroupId=org.jboss.seam -DartifactId=jboss-seam-gen \
            -Dversion=${DSTAMP}.${TSTAMP} -Dpackaging=jar -Dfile=/path/to/file
            Alternatively, if you host your own repository you can deploy the file there: mvn deploy:deploy-file -DgroupId=org.jboss.seam -DartifactId=jboss-seam-gen
            \
            -Dversion=${DSTAMP}.${TSTAMP} -Dpackaging=jar -Dfile=/path/to/file \
            -Durl=[url] -DrepositoryId=[id]

            Path to dependency:
            1) unspecified:unspecified:jar:0.0
            2) org.jboss.seam:jboss-seam-gen:jar:${DSTAMP}.${TSTAMP}

            ----------
            1 required artifact is missing.

            for artifact:
            unspecified:unspecified:jar:0.0

            from the specified remote repositories:
            central (http://repo1.maven.org/maven2)


            Total time: 1 second


            I'm also not a maven expert; is this a problem on my end?

            Thanks for your hard work!

            • 3. Re: seam-gen setup and maven
              Devon Hillard Novice

              I'm getting this error from the current head trying to use seam gen:


              Alita:~/Documents/workspaces/digitalsanctuary/jboss-seam modoc$ ./seam setup
              Buildfile: build.xml
              
              init:
              [artifact:dependencies] Downloading: org/jboss/seam/jboss-seam-gen/2.0.0.BETA1/jboss-seam-gen-2.0.0.BETA1.pom
              [artifact:dependencies] Downloading: org/jboss/seam/jboss-seam-gen/2.0.0.BETA1/jboss-seam-gen-2.0.0.BETA1.jar
              [artifact:dependencies] An error has occurred while processing the Maven artifact tasks.
              [artifact:dependencies] Diagnosis:
              [artifact:dependencies]
              [artifact:dependencies] Unable to resolve artifact: Missing:
              [artifact:dependencies] ----------
              [artifact:dependencies] 1) org.jboss.seam:jboss-seam-gen:jar:2.0.0.BETA1
              [artifact:dependencies]
              [artifact:dependencies] Try downloading the file manually from the project website.
              [artifact:dependencies]
              [artifact:dependencies] Then, install it using the command:
              [artifact:dependencies] mvn install:install-file -DgroupId=org.jboss.seam -DartifactId=jboss-seam-gen \
              [artifact:dependencies] -Dversion=2.0.0.BETA1 -Dpackaging=jar -Dfile=/path/to/file
              [artifact:dependencies] Alternatively, if you host your own repository you can deploy the file there: mvn deploy:deploy-file -DgroupId=org.jboss.seam -DartifactId=jboss-seam-gen \
              [artifact:dependencies] -Dversion=2.0.0.BETA1 -Dpackaging=jar -Dfile=/path/to/file \
              [artifact:dependencies] -Durl=[url] -DrepositoryId=[id]
              [artifact:dependencies]
              [artifact:dependencies] Path to dependency:
              [artifact:dependencies] 1) unspecified:unspecified:jar:0.0
              [artifact:dependencies] 2) org.jboss.seam:jboss-seam-gen:jar:2.0.0.BETA1
              [artifact:dependencies]
              [artifact:dependencies] ----------
              [artifact:dependencies] 1 required artifact is missing.
              [artifact:dependencies]
              [artifact:dependencies] for artifact:
              [artifact:dependencies] unspecified:unspecified:jar:0.0
              [artifact:dependencies]
              [artifact:dependencies] from the specified remote repositories:
              [artifact:dependencies] central (http://repo1.maven.org/maven2)
              [artifact:dependencies]
              
              BUILD FAILED
              /Users/modoc/Documents/workspaces/digitalsanctuary/jboss-seam/seam-gen/build.xml:19: Unable to resolve artifact: Missing:
              ----------
              1) org.jboss.seam:jboss-seam-gen:jar:2.0.0.BETA1
              
               Try downloading the file manually from the project website.
              
               Then, install it using the command:
               mvn install:install-file -DgroupId=org.jboss.seam -DartifactId=jboss-seam-gen \
               -Dversion=2.0.0.BETA1 -Dpackaging=jar -Dfile=/path/to/file
              Alternatively, if you host your own repository you can deploy the file there: mvn deploy:deploy-file -DgroupId=org.jboss.seam -DartifactId=jboss-seam-gen \
               -Dversion=2.0.0.BETA1 -Dpackaging=jar -Dfile=/path/to/file \
               -Durl=[url] -DrepositoryId=[id]
              
               Path to dependency:
               1) unspecified:unspecified:jar:0.0
               2) org.jboss.seam:jboss-seam-gen:jar:2.0.0.BETA1
              
              ----------
              1 required artifact is missing.
              
              for artifact:
               unspecified:unspecified:jar:0.0
              
              from the specified remote repositories:
               central (http://repo1.maven.org/maven2)
              
              
              Total time: 1 second
              Alita:~/Documents/workspaces/digitalsanctuary/jboss-seam modoc$
              
              


              I'm not a maven expert, so I don't know where to start looking.

              • 4. Re: seam-gen setup and maven
                Pete Muir Master

                Devon, Matt,

                I've made some changes to CVS which should help. You'll need to (having updated from CVS):

                1) Edit your build.properties and ensure you have no references to version and patchlevel in there (unless you really want them there!)
                2) Run ant clean build in the Seam root directory
                3) Run seam setup

                Please post back if you are having problems after this - sorry for the disruption!

                • 5. Re: seam-gen setup and maven
                  Matt Drees Master

                  Thanks Pete! Works great.

                  • 6. Re: seam-gen setup and maven
                    Damian Harvey Master

                    Pete,

                    I'm trying to use the nightly build from today (Build #350) and am getting the same problem:

                    Unable to resolve artifact: Missing:
                    ----------
                    1) org.jboss.seam:jboss-seam-gen:jar:2.0.0-CR2

                    I assume that the nightly builds would include the fix that you mention above?

                    The 3 steps you outlined don't work for me with this release.

                    Cheers,

                    Damian.