0 Replies Latest reply on Sep 30, 2007 3:48 PM by Bartosz Jamroz

    Maven2 - Interceptor class not found

    Bartosz Jamroz Newbie

      Hi !

      I`m developing a new project and I`m trying to use Seam. Trying couse I can`t step over the following error:

      21:26:36,953 WARN [ServiceController] Problem creating service jboss.j2ee:service=EJB3,module=ejb3.jar
      java.lang.RuntimeException: Interceptor class not found: org.jboss.seam.ejb.SeamInterceptor


      I`m building my project with maven2. Seam version 1.2.1.GA. Deployed on JBoss 4.0.5.GA

      Here is the pom file for the EJB module:
      <?xml version="1.0"?>
      <project>
       <parent>
       <artifactId>Inquisitor</artifactId>
       <groupId>com.blstream.inquisitor</groupId>
       <version>1.0-SNAPSHOT</version>
       </parent>
       <modelVersion>4.0.0</modelVersion>
       <groupId>com.blstream.inquisitor</groupId>
       <artifactId>ejb3</artifactId>
       <name>Inquisitor::${artifactId}</name>
       <packaging>ejb</packaging>
       <version>1.0-SNAPSHOT</version>
       <repositories>
       <repository>
       <id>JBossMaven2Repository</id>
       <name>JBoss Maven2 Repository</name>
       <url>http://repository.jboss.com/maven2</url>
       </repository>
       </repositories>
       <dependencies>
       <dependency>
       <groupId>junit</groupId>
       <artifactId>junit</artifactId>
       <version>3.8.1</version>
       <scope>test</scope>
       </dependency>
       <dependency>
       <groupId>jboss</groupId>
       <artifactId>jboss-ejb-api</artifactId>
       <version>4.2.0.GA</version>
       <scope>provided</scope>
       </dependency>
       <dependency>
       <groupId>jboss</groupId>
       <artifactId>jboss-seam</artifactId>
       <version>1.2.1.GA</version>
       <scope>provided</scope>
       </dependency>
       <dependency>
       <groupId>javax.persistence</groupId>
       <artifactId>persistence-api</artifactId>
       <version>1.0</version>
       <scope>provided</scope>
       </dependency>
       <dependency>
       <groupId>org.hibernate</groupId>
       <artifactId>hibernate-validator</artifactId>
       <version>3.0.0.ga</version>
       <scope>provided</scope>
       </dependency>
       </dependencies>
       <build>
       <plugins>
       <plugin>
       <artifactId>maven-ejb-plugin</artifactId>
       <configuration>
       <ejbVersion>3.0</ejbVersion>
       </configuration>
       </plugin>
       </plugins>
       <finalName>ejb3</finalName>
       </build>
      </project>


      the ejb-jar.xml :

      <?xml version="1.0" encoding="UTF-8"?>
      <ejb-jar xmlns="http://java.sun.com/xml/ns/javaee"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/ejb-jar_3_0.xsd"
       version="3.0">
      
       <interceptors>
       <interceptor>
       <interceptor-class>org.jboss.seam.ejb.SeamInterceptor</interceptor-class>
       </interceptor>
       </interceptors>
      
       <assembly-descriptor>
       <interceptor-binding>
       <ejb-name>*</ejb-name>
       <interceptor-class>org.jboss.seam.ejb.SeamInterceptor</interceptor-class>
       </interceptor-binding>
       </assembly-descriptor>
      
      </ejb-jar>
      


      web.xml from the web module:
      <?xml version="1.0" encoding="UTF-8"?>
      <web-app xmlns="http://java.sun.com/xml/ns/javaee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd"
       version="2.5">
      
       <!-- SEAM -->
       <listener>
       <listener-class>org.jboss.seam.servlet.SeamListener</listener-class>
       </listener>
      
       <!-- JSF -->
       <listener>
       <listener-class>org.apache.myfaces.webapp.StartupServletContextListener</listener-class>
       </listener>
       <servlet>
       <servlet-name>Faces Servlet</servlet-name>
       <servlet-class>javax.faces.webapp.FacesServlet</servlet-class>
       <load-on-startup>1</load-on-startup>
       </servlet>
       <servlet-mapping>
       <servlet-name>Faces Servlet</servlet-name>
       <url-pattern>*.jsf</url-pattern>
       </servlet-mapping>
       <welcome-file-list>
       <welcome-file>index.jsf</welcome-file>
       </welcome-file-list>
      </web-app>
      


      Any idea why JBoss deployer cannot find SeamInterceptor ?