1 Reply Latest reply on Oct 25, 2007 7:56 PM by Samuel Doyle

    Isn't the Core JSTL suppose to be supported?

    Samuel Doyle Apprentice

      Yet when I use the c:forEach and c:choose I get Seam debug window with no useful information in it whatsoever. There is no exception being thrown in the logs.

      <c:forEach items="#{cameraAccessor.findCamerasForCameraGroup()}" var="camera">
      
       <c:choose>
       <c:when test='#{camera.getDirection() eq "N"}'>
       <li id="northCam"><a class="off" href="#"
       title="North Camera"
       onClick="testFunction('N', '#{camera.getId()}');">N</a></li>
       </c:when>
       <c:when test='#{camera.getDirection() eq "W"}'>
       <li id="westCam" ><a class="off" href="#"
       title="West Camera"
       onClick="testFunction('W', '#{camera.getId()}');">W</a></li>
       </c:when>
       <c:when test='#{camera.getDirection() eq "E"}'>
       <li id="eastCam" ><a class="off" href="#"
       title="East Camera"
       onClick="testFunction('E', '#{camera.getId()}');">E</a></li>
       </c:when>
       <c:when test='#{camera.getDirection() eq "S"}'>
       <li id="southCam"><a class="off" href="#"
       title="South Camera"
       onClick="testFunction('S', '#{camera.getId()}');">S</a></li>
       </c:when>
       <c:otherwise>
       </c:otherwise>
       </c:choose>
       <li id="allCam"><a class="off" href="#"
       title="All Cameras"
       onClick="testFunction('ALL', '#{camera.getId()}');">ALL</a></li>
      
       </c:forEach>


      Both cameraAccessor and camera are Seam components.

      Thanks, S.D.

        • 1. Re: Isn't the Core JSTL suppose to be supported?
          Samuel Doyle Apprentice

          Please disregard this, this wasn't the problem.

          This initially worked but when I added the jstl conditional checking it stopped so naturally I blamed it on the jstl. I rolled back everything and it was still not working.

          The problem was the method signature used to take a Long parameter but was changed to long. The paramter being passed to the page was:

          <param name="groupID" value="#{cameraAccessor.cameraGroupID}"
           converterId="javax.faces.Long"/>

          Using a javax.faces.Long converter. I guess autoboxing isn't supported in this matter.

          There was no way I could see in the Seam Debug page to indicate this problem. It was only a matter of going through all elements that I discovered this.

          S.D.