1 Reply Latest reply on Nov 19, 2007 5:21 AM by Pete Muir

    JBoss Seam dependencies

    Erik Hellman Newbie

      I'm trying to find information on which APIs and their versions that are required for each Seam-release.

      We are currently using JBoss Seam 1.2.1 (an upgrade to version 2.0.0 is not possible at this time). Can someone please tell me which versions and implementations of JSF are required and supported? The RichFaces and Ajax4JSF-components that comes with the release is not complete (i.e., there are some JSF tags missing) and the facelets-implementation contains a bug in the ui:repeat tag. These issues are not described in any of the official documentations available.

      We would like to upgrade to the latest RichFaces (3.1.2), but that seems to require JSF 1.2, which doesn't seem to work with JBoss Seam 1.2.1. My guess is that there are other dependencies to different libraries that we might run into (Hibernate version, jBPM version etc.).

      A list of the specific libraries required for each Seam-version would be greatly appreciated!

      Thanks!

      // Erik