5 Replies Latest reply on Feb 2, 2008 12:50 PM by Kevin Galligan

    Help with seam create-entities

    linux enthusiast Newbie

      I just installed the jboss-seam-2.0.0.GA and I'm having issues running "seam generate_entities" option. Tool doesn't seam to generate the Entities from the tables in the schema.

      Here are the steps taken to reverse engineer the project.

      System : Ubuntu
      Install dir: /home/user/jboss-seam-2.0.0.GA
      DB : Oracle XE

      Step 1.
      From /home/user/jboss-seam-2.0.0.GA ran "seam setup" and the build.properties file I have is as follows

      #Generated by seam setup
      #Sat Dec 22 10:58:27 PST 2007
      hibernate.connection.password=xxxxxx
      workspace.home=/home/user/Projects/jboss-seam
      model.package=org.manna.TestProj
      action.package=org.manna.TestProj
      test.package=org.manna.TestProj.test
      hibernate.default_catalog.null=
      hibernate.default_schema=spring
      driver.jar=/usr/lib/oracle/xe/app/oracle/product/10.2.0/server/jdbc/lib/ojdbc14.jar
      database.type=oracle
      richfaces.skin=blueSky
      database.drop=n
      project.name=TestProj
      hibernate.connection.username=xxx
      hibernate.connection.driver_class=oracle.jdbc.driver.OracleDriver
      hibernate.cache.provider_class=org.hibernate.cache.HashtableCacheProvider
      project.type=ear
      icefaces.home=
      database.exists=y
      jboss.home=/home/user/jboss-4.2.2.GA
      hibernate.dialect=org.hibernate.dialect.Oracle10gDialect
      hibernate.connection.url=jdbc\:oracle\:thin\:@user-desktop\:1521\:XE

      Step 2.
      Ran "seam create-project"
      This command seems to create a directory under
      /home/user/Projects/jboss-seam as "TestProj"

      Step 3
      Ran "seam create-entities"
      Here are the observations,
      3.1 If I do not specify the schema in the build.properties, the tool seems to look at all the tables not sure why and gives all sort of errors?
      3.2 After I specify the schema, the command completes as follows
      .....
      [hibernate] Dec 22, 2007 11:31:43 AM org.hibernate.connection.DriverManagerConnectionProvider close
      [hibernate] INFO: cleaning up connection pool: jdbc:oracle:thin:@user-desktop:1521:XE
      [hibernate] Dec 22, 2007 11:31:43 AM org.hibernate.tool.Version
      [hibernate] INFO: Hibernate Tools 3.2.0.b10
      [hibernate] 2. task: generic exportertemplate: view/list.xhtml.ftl
      [hibernate] 3. task: generic exportertemplate: view/view.xhtml.ftl
      [hibernate] 4. task: generic exportertemplate: view/view.page.xml.ftl
      [hibernate] 5. task: generic exportertemplate: view/edit.xhtml.ftl
      [hibernate] 6. task: generic exportertemplate: view/edit.page.xml.ftl
      [hibernate] 7. task: generic exportertemplate: src/EntityList.java.ftl
      [hibernate] 8. task: generic exportertemplate: view/list.page.xml.ftl
      [hibernate] 9. task: generic exportertemplate: src/EntityHome.java.ftl
      [hibernate] 10. task: generic exportertemplate: view/layout/menu.xhtml.ftl
      Dec 22, 2007 11:31:43 AM org.hibernate.connection.DriverManagerConnectionProvider close
      INFO: cleaning up connection pool: jdbc:oracle:thin:@user-desktop:1521:XE
      [javaformatter] Java formatting of 1 files completed. Skipped 0 file(s).
      [echo] Type 'seam restart' and go to http://localhost:8080/cdm

      BUILD SUCCESSFUL
      Total time: 4 seconds

      But I could not find the Entities Getting created. Not sure how the driver is getting a list of tables. How can I debug this?

      Really appreciate any help.

      Thanks.
      vinoo