3 Replies Latest reply on Feb 11, 2008 10:00 AM by Rodrigo G. Hartmann

    Seam/jBpm deployment on linux - need hints

    Rodrigo G. Hartmann Newbie

      Hello, everyone.

      I have a Seam application packaged as an .EAR file. All works very well and without any problems, on a glassfish AS installed in a windows (blergh) machine. It is running in a windows instance because I couldn't make it run on linux =/

      First and foremost, my .EAR has all the third party libraries it needs packaged with it, in a /lib folder. I do not have to copy these jars to the glassfish mydomain/lib folder in windows, it all works well out of the box by simply deploying the EAR file. That includes all hibernate libraries and the Seam dependencies. All works fine, no warns or errors on the deployment.

      The same is true for the jBpm process. It works well, without errors, through the many pageflows it uses.

      In Linux, however... I cannot deploy the EAR by itself. In order for the deployment to work, I must copy all the jars of the EAR/lib folder to the mydomain/lib folder in glassfish.

      After that, the deploy still fails with a "cannot deploy process definition" error (URL is null, etc..). The .EAR is exactly the same that is deployed in Windows. I have also tried all sorts of sane and insane workarounds, such as throwing the myprocess jpdl file everywhere through the EAR filesystem and the server itself.

      So, my questions are:

      1) Any clues why the linux instance of glassfish explicitly requires my libraries to be deployed also "outside" the .EAR file?
      2) Any clues why seam/jbpm is unable to find my process definition file, in linux only?

      I'm running out of both time, patience, and options... =D So if anyone has run into similar problems, maybe that would help me find out what's wrong with my environment here..

      Sorry for the long post, please forgive my english, and thanks in advance ;)

      Rodrigo

        • 1. Re: Seam/jBpm deployment on linux - need hints
          Jan te Beest Newbie

          It sounds to me as a difference between OS installs of Glassfish. Maybe you should take your problem to the Glassfish forums (or whatever they have, I'm not familiar). Not trying to be rude, I just think they might be more able to help. This is not a SEAM issue.

          BTW, your English is better than modern youth's Dutch here :P

          Regards,
          Jan

          • 2. Re: Seam/jBpm deployment on linux - need hints
            Rodrigo G. Hartmann Newbie

            Thanks jteb,

            I understand what you say, and I agree - the reason I haven't brought this up at the Glassfish forum yet is that I was hoping it was a specific Seam issue. So I posted to see if such a problem was a common one, or a known issue for someone lingering here.

            As far as the versions of glassfish are concerned, they are the same build version - only different concerning the OSes at hand. I also suspect that this has something to do with how glassfish searches for files/resources in different OSes...

            Thanks again!

            Rodrigo

            • 3. Re: Seam/jBpm deployment on linux - need hints
              Rodrigo G. Hartmann Newbie

              Another curious thing.

              If I run the application through Netbeans (starting glassfish through the IDE and deploying the application through it as well), even on Linux and using the same version of the application server, it all works well.

              The problem can only be noticed by using the deploy tool available at the admin console web app.

              Very odd indeed. I'm confused :D

              Rodrigo