4 Replies Latest reply on Aug 21, 2006 1:52 PM by Peter Davies

    jbossweb-1.0.0.GA problems

    Swarn Dhaliwal Newbie

      I downloaded jbossweb-1.0.0.GA for windows and tried to start it. It pops up a error dialog box whose text reads as follows :

      The ordinal 3214 could not be located in the dynamic link library.

      After clicking ok on this dialog about 3 times, the server startsup but prints the following error message in the log

      ERROR [AprLifecycleListener] The Apache Tomcat Native library that JBoss Web requires (only the HTTP connector will be available) was not found on the java.library.path.

      This seems to indicate the native support would not work in the server. I was wondering if anybody else had a similar problem

        • 1. Re: jbossweb-1.0.0.GA problems
          Peter Johnson Master

          I am running this version on my Windows boxes just fine. I suspect that the download was corrupted. In the bin directory, is there a 'native' subdirectory? It should contain the following:

          >dir
           Volume in drive C has no label.
           Volume Serial Number is 2473-5A25
          
           Directory of C:\jboss\web\jbossweb-1.0.0.GA\bin\native
          
          07/24/2006 08:17 PM <DIR> .
          07/24/2006 08:17 PM <DIR> ..
          06/11/2006 11:59 PM 139,264 libapr-1.dll
          06/11/2006 11:59 PM 1,019,904 libeay32.dll
          06/11/2006 11:59 PM 106,496 libtcnative-1.dll
          06/11/2006 11:59 PM 522 Microsoft.VC80.CRT.manifest
          06/11/2006 11:59 PM 479,232 msvcm80.dll
          06/11/2006 11:59 PM 548,864 msvcp80.dll
          06/11/2006 11:59 PM 626,688 msvcr80.dll
          06/11/2006 11:59 PM 294,912 openssl.exe
          06/11/2006 11:59 PM 196,608 ssleay32.dll
           9 File(s) 3,412,490 bytes
           2 Dir(s) 18,774,929,408 bytes free


          • 2. Re: jbossweb-1.0.0.GA problems
            Peter Davies Newbie

            Was this the answer to this problem? I am having the same issue and I do not believe the download is corrupt (tried 2x). I believe it has to do with a libeay32.dll OpenSSL dll file which is in Windows\Systems32. This library is the same (but older) than the one provided in bin\native. If I were to guess, I suspect it was put there by cygwin as I have OpenSSL support enabled there.

            Note that c:\windows\system32 appears before the bin\native in the java.library.path:

            13:23:58,139 ERROR [AprLifecycleListener] The Apache Tomcat Native library that
            JBoss Web requires (only the HTTP connector will be available) was not found on
            the java.library.path: C:\Program Files\Java\jdk1.5.0_08\bin;.;C:\WINDOWS\system
            32;C:\WINDOWS;C:\develop\jboss\jbossweb-1.0.0.GA\bin\\native;C:\develop\jboss\jb
            ossweb-1.0.0.GA\bin\\native;C:\develop\jboss\jbossweb-1.0.0.GA\bin\\native;C:\de
            velop\jboss\jbossweb-1.0.0.GA\bin\native;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDO
            WS\System32\Wbem;C:\Program Files\ATI Technologies\ATI.ACE\;C:\Program Files\Int
            el\Wireless\Bin\;C:\Program Files\QuickTime\QTSystem\;C:\develop\components\apac
            he-ant-1.6.5\bin


            What is confusing is I have tried explicitly setting java.library.path to put bin\native first and it still does not work (yet the line above will indicate the correct order).

            If I remove libeay32.dll from the windows\system32 area, I get a different ordinal number in the error message (968) which leads me to believe there is some interaction here.

            • 3. Re: jbossweb-1.0.0.GA problems
              Swarn Dhaliwal Newbie

              I think the old version of libeay32.dll in the C:\windows\system32 was creating the problem for me. Once I removed that file, my install works fine

              • 4. Re: jbossweb-1.0.0.GA problems
                Peter Davies Newbie

                I found I had to remove both libeay32.dll and ssleay32.dll from windows\system32 and then JBossWeb started without issue. Of course, who knows what else I just broke.