3 Replies Latest reply on Feb 13, 2007 5:48 AM by Jean-Frederic Clere

    Jboss server crach while retrieving blob data from oracle DB

    Abraham secter Newbie

      Hi,

      i have problem ( jboss crash )while tried to get blob data from oracle db using php.

      my code is :
      $query = "SELECT * FROM \"testing_blob\" WHERE \"file_id\" = '1";
      $result = ociparse($conn,$query);
      ociexecute($result);
      //$row = oci_fetch_array($result);

      while ( $row = oci_fetch_assoc($result))
      {
      echo($row['files']->load()."\n");
      }


      when i run the script the jboss crash and the error is :

      21:19:10,265 INFO [ChannelSocket] JK: ajp13 listening on /0.0.0.0:8009
      21:19:10,296 INFO [Server] JBoss (MX MicroKernel) [4.0.4.GA (build: CVSTag=JBos
      s_4_0_4_GA date=200605151000)] Started in 48s:48ms
      #
      # An unexpected error has been detected by HotSpot Virtual Machine:
      #
      # EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x03f794f9, pid=1704, tid=2964
      #
      # Java VM: Java HotSpot(TM) Client VM (1.4.2_09-b05 mixed mode)
      # Problematic frame:
      # C [php5ts.dll+0x194f9]
      #
      # An error report file with more information is saved as hs_err_pid1704.log
      #
      # If you would like to submit a bug report, please visit:
      # http://java.sun.com/webapps/bugreport/crash.jsp
      #

      [error occurred during error reporting, step 270, id 0xc0000005]

      Press any key to continue . . .

      ===============================================

      The jboss can run php very well other than reading blob data from database.

      Any one face this problem before ? any solution ?

      Thanks A lot

      Regards
      Abraham