4 Replies Latest reply on May 6, 2007 11:32 PM by Peter Johnson

    jboss-4.0.5.GA with Windows Vista Home Premium + jdk1.5.0_11

    shivang vyas Newbie

      I am trying to install JBoss application server on my laptop. I downloaded the jboss-4.0.5.GA.zip from the jboss website and extracted on my C drive at C:\jboss-4.0.5.GA and jdk1.5.0_11 installed at C:\Java\jdk1.5.0_11. JBOSS_HOME & JAVA_HOME have been set to the afore mentioned locations respectively. Now I tried running the server and it booted up successfully. Following is the mesg at command prompt:
      16:03:50,477 INFO [DLQ] Bound to JNDI name: queue/DLQ
      16:03:50,852 INFO [ConnectionFactoryBindingService] Bound ConnectionManager 'jb
      oss.jca:service=ConnectionFactoryBinding,name=JmsXA' to JNDI name 'java:JmsXA'
      16:03:51,004 INFO [TomcatDeployer] deploy, ctxPath=/jmx-console, warUrl=.../dep
      loy/jmx-console.war/
      16:03:51,714 INFO [Http11BaseProtocol] Starting Coyote HTTP/1.1 on http-0.0.0.0
      -8080
      16:03:51,861 INFO [ChannelSocket] JK: ajp13 listening on /0.0.0.0:8009
      16:03:51,882 INFO [JkMain] Jk running ID=0 time=0/50 config=null
      16:03:51,891 INFO [Server] JBoss (MX MicroKernel) [4.0.5.GA (build: CVSTag=Bran
      ch_4_0 date=200610162339)] Started in 20s:270ms

      However, When I try to bring up the console ( http://localhost:8080/jmx-console/), I get the following exception everytime.
      16:04:24,926 ERROR [PoolTcpEndpoint] Endpoint ServerSocket[addr=/0.0.0.0,port=0,
      localport=8080] ignored exception: java.net.SocketException: select failed
      java.net.SocketException: select failed
      at java.net.PlainSocketImpl.socketAccept(Native Method)
      at java.net.PlainSocketImpl.accept(PlainSocketImpl.java:384)
      at java.net.ServerSocket.implAccept(ServerSocket.java:450)
      at java.net.ServerSocket.accept(ServerSocket.java:421)
      at org.apache.tomcat.util.net.DefaultServerSocketFactory.acceptSocket(De
      faultServerSocketFactory.java:60)
      at org.apache.tomcat.util.net.PoolTcpEndpoint.acceptSocket(PoolTcpEndpoi
      nt.java:407)
      at org.apache.tomcat.util.net.PoolTcpEndpoint.run(PoolTcpEndpoint.java:6
      47)
      at java.lang.Thread.run(Thread.java:595)
      16:04:24,986 WARN [PoolTcpEndpoint] Reinitializing ServerSocket


      Please help me figure out if I am missing something here. I followed the same steps on my PC which has Windows XP Home + jdk1.5.0_11 and it works perfectly fine.
      I also tried using jboss-3.2.4 and jboss-3.2.8 but same results. Any help in this regard will be appreciated. Thanks in advance.

        • 1. Re: jboss-4.0.5.GA with Windows Vista Home Premium + jdk1.5.
          Peter Johnson Master

          I have run JBoss AS 4.0.5 successfully on Vista (Ultimate), so I know that it works. Googling the exception (I used "SocketException select failed") it would appear that the problem is with the TCP/IP stack (perhaps with winsock). Try this, Vista automatically installs both IPv4 and IPv6 support. Try unsetting IPv6 - simply uncheck it in the list of features in the Connection Properties dialog, if you can even find the dialog, the Vista designers decided to make it as difficult as possible to find this dialog. (Let it be known that it took great effort for me not to make a disparaging remark regarding said designers...)

          By the way, did you buy the laptop with Vista, or did you upgrade?

          And finally, your question has nothing to do with the JBoss Web Server, and thus should have been asked in either the Beginners Corner, or Installation, Configuration & Deployment.

          • 2. Re: jboss-4.0.5.GA with Windows Vista Home Premium + jdk1.5.
            shivang vyas Newbie

            Thank You very much for your reply and I apologise for posting the question in the wrong section, this is my first post and I wasn't sure where the question relating to application server was to be posted. I upgraded to Vista, laptop came with windows xp home to start with.

            • 3. Re: jboss-4.0.5.GA with Windows Vista Home Premium + jdk1.5.
              shivang vyas Newbie

              Peter, I unchecked the IPV6 for both wirelessLAn and LAN network connections. I am not sure if that is where you wanted me to unset them. After that I started the server and tried getting to the console but I still get the same exception as earlier. Any other ideas?

              • 4. Re: jboss-4.0.5.GA with Windows Vista Home Premium + jdk1.5.
                Peter Johnson Master

                A few other suggestions.

                Get the latest driver for your NIC (both wired and wireless). Good luck with that since it depends on the manufacturer providing a Vista-specific driver.

                Try turning off Limited User Access. It sometimes (hah! often!) screws you up in weird ways.

                Try turning off the firewall. (I vaguely recall configuring the firewall to give java.exe full access rights.)

                Wipe your hard drive and install Linux instead. :-) (Sorry, but I couldn't help myself!) Of course, that comes with its own set of headaches.