1 Reply Latest reply on May 29, 2008 2:35 AM by jaikiran pai

    Jboss AS 4.2.2.GA cannot access port 80 from another machine

    Karel Jelinek Newbie

      I have a problem with running Jboss AS on port 80. I have read, that I must run it under root user, because another users cant user ports lower that 1234. So I have no problem with run jboss with port 80 and I can access my deployed application on localhost. But I cant access on jboss server if i try to connect from another computer.
      Tha strange thing is, that if I run apache web server on the same machine, under port 80, I can access it on localhost and also from another computer. So I think it cant be problem with some firewall. Just to be sure I shutdown firewalls on both machines.
      I have windows XP and under it I run vmware workstation where I have openSuse 10.3 installed. I can ping linux machine from windows and windows machine from linux. As I said I can access apache web server from windows if apache runs under linux on port 80. But I cant access jboss server from windows if it runs on linux under port 80.

      I think that it is some problem with jboss configuration.
      When I change configuration from port 8080 to port 80, I changed files
      jboss-4.2.2.GA\server\default\deploy\http-invoker.sar\META-INF\jboss-service.xml (I changed all 8080 to 80)
      and
      jboss-4.2.2.GA\server\default\deploy\jboss-web.deployer\server.xml (I changed only connector part)

      <Connector port="80" address="${jboss.bind.address}"
       maxThreads="250" maxHttpHeaderSize="8192"
       emptySessionPath="true" protocol="HTTP/1.1"
       enableLookups="false" redirectPort="8443" acceptCount="100"
       connectionTimeout="20000" disableUploadTimeout="true" />



      Thanks for some tips