5 Replies Latest reply on Oct 12, 2007 12:33 PM by Elias Ross

    Unable to build the project

    Elias Ross Master

      Perhaps my "maven-fu" isn't up to par, but "maven install" is not working to build the SVN head revision.

      The "container" build fails, apparently missing some "org.jboss.xb" classes. Missing dependencies?

      [INFO] Compiling 245 source files to c:\src\workspace\microcontainer\container\t
      arget\classes
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Compilation failure
      c:\src\workspace\microcontainer\container\src\main\org\jboss\javabean\plugins\xm
      l\ConstructorInterceptor.java:[27,49] package org.jboss.xb.binding.sunday.unmars
      halling does not exist
      
      c:\src\workspace\microcontainer\container\src\main\org\jboss\javabean\plugins\xm
      l\ConstructorInterceptor.java:[34,44] cannot find symbol
      symbol: class DefaultElementInterceptor
      public class ConstructorInterceptor extends DefaultElementInterceptor
      
      c:\src\workspace\microcontainer\container\src\main\org\jboss\javabean\plugins\xm
      l\JavaBeanSchemaInitializer20.java:[26,49] package org.jboss.xb.binding.sunday.u
      nmarshalling does not exist


        • 1. Re: Unable to build the project
          Ales Justin Master

          Hmm ... I'm not seeing anything simialr. And I do build MC quite often these days. :-)
          Tried nuking the whole thing?

          • 2. Re: Unable to build the project
            Elias Ross Master

            Okay, looks like something I was doing to reduce the dependency count ... Microcontainer it is not.

            But I'm running into this now on JDK 1.6:

            2007-10-11 16:02:49,640 WARN [Bootstrap] (main) Deployer validate failed
            java.lang.IllegalStateException: Incompletely deployed:
            
            *** DEPLOYMENTS IN ERROR: Name -> Error
            AspectManager -> java.lang.IllegalStateException: Class not found: [B
            
            *** DEPLOYMENTS MISSING DEPENDENCIES: Name -> Dependency{Required State:Actual State}
            InstallConfiguredCallback$AspectBinding -> AspectManager{Configured:**ERROR**}
            InstallConfiguredCallback -> AspectManager{Create:**ERROR**}, AspectManager{Start:**ERROR**}, Configurator{Instantiated:Installed}
            
             at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.internalValidate(AbstractKernelDeployer.java:260)
             at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.validate(AbstractKernelDeployer.java:174)
             at com....mc.Bootstrap.run(Bootstrap.java:119)
            


            • 3. Re: Unable to build the project
              Elias Ross Master

              I checked in a test+fix for this .. hope it's okay

              • 4. Re: Unable to build the project
                Ales Justin Master

                 

                "genman" wrote:
                I checked in a test+fix for this .. hope it's okay

                I removed the Signature(Method) constructor, since it should be all (Method, Fields, Constructor, MethodInfo, FieldsInfo, ...) or nothing.

                And I also refactored your test case to use existing assertion util methods on jboss test classes.

                The test was added to a MetaDataAll testsuite.


                • 5. Re: Unable to build the project
                  Elias Ross Master

                  Probably should have ones for java.lang.reflect fields at least. The Javaassist classes create an external dependency I think.

                  One thing I ran into creating tests is that the compiler can't figure out how to distinguish these two constructors:

                   public Signature(String... parameters)
                   public Signature(String name, String... parameters)
                  

                  I would probably drop the first at least.