First of all, we are introducing an extra interface: Replier. The replier is used by the reply activity. Different implementations of the replier might have different threading models.
Related to that i'ld like to propose the following name changes:
ServiceInvoker --> Invoker
ServiceInvocationHandler --> Receiver
so you got Receiver, Invoker and Replier. sounds better, no ?
Yes, it is better. For sur easyeat to understand...