i'm going to start a renaming and package restructuring.
the main goal is to better separate the api from the implementation from a usage perspective. the goal is not to support different implementations. but to make it clear to a user when they are using intended api classes and when they are using internal classes.
this will also help us to prioritize what needs to be tested.
as far as i can see now, the main api classes are what is now located in org.jbpm.pvm. i went over those yesterday and i removed all dependencies outside of that package (except for the method implementations of the ProcessFactory)
i will probably structure the internal classes under org.jbpm.internal or org.jbpm.pvm.internal
so users will very clearly see when they start to use internals instead of the api.
this is a good idea as this will improve the PVM usability.
on the tests side, I agree we should focus on the api level first and the on the internals.
For the package name I would prefer org.jbpm.pvm.internal