3 Replies Latest reply on May 14, 2013 11:42 AM by Greg HENRY

    "Name of XA node not defined" despite it is set as nodeIdent

    Rico Neubauer Novice

      Hi,

      on JBoss start-up I get a warning:

      WARN [arjLoggerI18N] [com.arjuna.ats.arjuna.coordinator.TxControl_1] - Name of XA node not defined. Using a00677d:102d:486e0d8d:0


      According to this post: http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4159219 this should only arise in the case of:

      that looks like misconfiguration - that value should be in the default config file. Either they have edited it out the file or the file is not being found. ensure jbossts etc dir is on the classpath (yes the dir itself, not the files in it). then check the file etc/jbossjta-properties.xml file has com.arjuna.ats.arjuna.xa.nodeIdentifier specified in it.


      My jbossjta-properties.xml has com.arjuna.ats.arjuna.xa.nodeIdentifier specified in it, but I still get the warning, it seems to be related to the jboss.server.data.dir pointing to a custom directory.

      The default layout
      jboss
      - server
      -- default
      ---- data
      works without warning, but my layout:
      root
      - data
      - jboss
      -- configname
      results in Name of XA node not defined.

      Already tried to add root/data and root/data/tx-object-store to the CP, which did not help.
      Could anyone assume what was meant with "jbossts etc dir" exactly?

        • 1. Re:
          Jonathan Halliday Master

          The configuration mechanism is specified in the documentation, but roughly speaking the dir containing the jbossjta-properties.xml file needs to be on the classpath. In JBossAS it is by default, since the server conf dir is part of the classpath:

          14:52:18,736 DEBUG [Server] Boot url list: [file:/jboss-4.2.2.GA/server/default/conf/]
          14:52:18,736 DEBUG [Server] Creating loader for URL: file:/jboss-4.2.2.GA/server/default/conf/

          If you mess around with the server configuration, you need to ensure the properties file can still be found on the classpath.

          • 2. Re:
            Rico Neubauer Novice

            Thanks for your answer, but sadly this is not the problem; my conf-directory (containing jbossjta-properties.xml) is located in the classpath:

            Boot url list: [file:D:/test/BIS6-3-3/jboss/myConf/conf/]
            Creating loader for URL: file:D:/test/BIS6-3-3/jboss/myConf/conf/


            • 3. Re:
              Greg HENRY Newbie

              Hum , this is a little bit late but .. if anyone have the same issue ...

               

              Find myself with the same (almost) problem , and find that JTA doesn't load the conf/jbossjta-properties.xml file if the conf directory url doesn't start with a slash ..

              URL file:D:/test/BIS6-3-3/jboss/myconf/conf doesn't work

               

              but

               

              URL file:/D:/test/BIS6-3-3/jboss/myconf/conf work !!!

               

              The trouble is that only jta make problem .. all other service depending on the conf directory work the same as usual with the correct or wrong url .

               

               

              Hope this can help

              Greg