5 Replies Latest reply on Sep 4, 2006 2:42 AM by Chris McQuillan

    Trailblazer Loanbroker error

    Chris McQuillan Newbie

      Hi all - I'm new to Jboss so hope someone can help. I have downloaded jboss-4.0.GA with EJB and JBossESB4.0Beta1 onto a Suse 10 linux server. The AS is up and running and testJBossESB.sh works OK. After some fiddling around, including moving BaseException.java into the trailblazer/bankloanbrokerdemo/java/src/org/jboss/soa.esb directory, I have managed to build and deploy the loanbroker demo. However when I point my browser to http::8080/loanbroker I get the following error:

      An error occurred at line: 111 in the jsp file: /index.jsp
      Generated servlet error:
      The method setTimeout(int) is undefined for the type LoanBrokerWSBindingStub

      Looking at LoanBrokerWSBindingStub.java I can see no setTimeout method. If I comment out the offending line in the index.jsp and redploy then I get:

      An error occurred at line: 111 in the jsp file: /index.jsp
      Generated servlet error:
      Unreachable catch block for ServiceException. This exception is never thrown from the try statement body

      Seems that either I have faile dot follow the Trailblazer instructions correctly (but they're fairly simple and short - ant configure, ant deploy) or there's something not right in the source. Anyone able to help?

        • 1. Re: Trailblazer Loanbroker error
          Daniel Brum Novice

          Sounds like some deploy issues. You should not have had to move any java source files anywhere, everything builds and deploys from the source folders where they were shipped from.

          Once you run 'ant deploy' in the TrailBlazer dir, you should try a http://localhost:8080/jbossws which is the JBoss WebServices console application which let's you inspect the deployed WebServices.

          There is definetely something going on in your deploy, as I just tried it with a fresh download, a new JBoss, and it all deployed and ran fine - i tried it on a new vm image i setup for testing.

          thanks

          • 2. Re: Trailblazer Loanbroker error
            Chris McQuillan Newbie

            Daniel - thanks - I'll try a new clean download and redeploy. Last time I took the SVN trunk/product tree via the Eclipse SVN plugin. The Getting Started Guide says to use "trunk" as the root direcotry which I may have misunderstood. What level in the tree do you recommend?

            • 3. Re: Trailblazer Loanbroker error
              Daniel Brum Novice

              Trunk is "Work in Progress" and I would not use that. You should get the Beta1 release from here: http://labs.jboss.com/portal/jbossesb/downloads

              I'm not sure why the Getting Started Guide would point you to the Trunk, only take the Trunk if you want the latest snapshot, or need a change which is only there, etc.

              thanks

              • 4. Re: Trailblazer Loanbroker error
                Chris McQuillan Newbie

                OK - I'll start over with the right source. Thanks!

                • 5. Re: Trailblazer Loanbroker error
                  Chris McQuillan Newbie

                  Hi again
                  I downloaded the source from http://labs.jboss.com/portal/jbossesb/downloads and went through the instructions in the Getting Started and TrailBlazer docs again - same result!
                  Point that might be an ah-hah is that when I did the ant deploy in the bankloanbrokerdemo folder it complained:

                  /usr/local/JBossESB_4.0Beta1/docs/samples/trailblazer/bankloanbrokerdemo/build.xml:63: /usr/local/JBossESB_4.0Beta1/docs/samples/trailblazer/bankloanbrokerdemo/product/build/dist/lib not found

                  I could "fix" that by editing out the product path in the build.xml (3 occurences) - then I once again had the compile errors:

                  org.jboss.esb.samples.loanbroker.compile:
                  [javac] Compiling 25 source files to /usr/local/JBossESB_4.0Beta1/docs/samples/trailblazer/bankloanbrokerdemo/build/classes/loanbroker
                  [javac] /usr/local/JBossESB_4.0Beta1/docs/samples/trailblazer/bankloanbrokerdemo/java/src/org/jboss/soa/esb/loanbroker/LoanBrokerException.java:3: cannot find symbol
                  [javac] symbol : class BaseException
                  [javac] location: package org.jboss.soa.esb
                  [javac] import org.jboss.soa.esb.BaseException;
                  [javac] ^
                  [javac] /usr/local/JBossESB_4.0Beta1/docs/samples/trailblazer/bankloanbrokerdemo/java/src/org/jboss/soa/esb/loanbroker/LoanBrokerException.java:8: cannot find symbol
                  [javac] symbol: class BaseException
                  [javac] public class LoanBrokerException extends BaseException {
                  [javac] ^
                  [javac] /usr/local/JBossESB_4.0Beta1/docs/samples/trailblazer/bankloanbrokerdemo/java/src/org/jboss/soa/esb/samples/loanbroker/actions/ProcessBanksFileResponse.java:28: package org.jboss.soa.esb.actions does not exist
                  [javac] import org.jboss.soa.esb.actions.AbstractFileAction;
                  [javac] ^

                  and so on. Last time around I fixed this by moving BaseException.class into the TrailBlazer src folder - Daniel advises thsi should not be necessary.

                  Freely admit I might be doing something dumb - perhaps I should move the project to under a "product" directory?

                  Thanks

                  CMQ