5 Replies Latest reply on Sep 8, 2006 3:12 AM by Chris McQuillan

    Still having Trailblazer problems

    Chris McQuillan Newbie

      Hi again

      Reposting this from my previous topic just in case no-one sees it there . . .

      I cleaned up my environment and downloaded the JBossESB source from http://labs.jboss.com/portal/jbossesb/downloads and went through the instructions in the Getting Started and TrailBlazer docs again - same result - the bankloanbroker demo isn't worknig for me.

      Point that might be an ah-hah is that when I did the ant deploy in the bankloanbrokerdemo folder it complained:

      /usr/local/JBossESB_4.0Beta1/docs/samples/trailblazer/bankloanbrokerdemo/build.xml:63: /usr/local/JBossESB_4.0Beta1/docs/samples/trailblazer/bankloanbrokerdemo/product/build/dist/lib not found

      I could "fix" that by editing out the product path in the build.xml (3 occurences) - then I once again had the compile errors:

      org.jboss.esb.samples.loanbroker.compile:
      [javac] Compiling 25 source files to /usr/local/JBossESB_4.0Beta1/docs/samples/trailblazer/bankloanbrokerdemo/build/classes/loanbroker
      [javac] /usr/local/JBossESB_4.0Beta1/docs/samples/trailblazer/bankloanbrokerdemo/java/src/org/jboss/soa/esb/loanbroker/LoanBrokerException.java:3: cannot find symbol
      [javac] symbol : class BaseException
      [javac] location: package org.jboss.soa.esb
      [javac] import org.jboss.soa.esb.BaseException;
      [javac] ^
      [javac] /usr/local/JBossESB_4.0Beta1/docs/samples/trailblazer/bankloanbrokerdemo/java/src/org/jboss/soa/esb/loanbroker/LoanBrokerException.java:8: cannot find symbol
      [javac] symbol: class BaseException
      [javac] public class LoanBrokerException extends BaseException {
      [javac] ^
      [javac] /usr/local/JBossESB_4.0Beta1/docs/samples/trailblazer/bankloanbrokerdemo/java/src/org/jboss/soa/esb/samples/loanbroker/actions/ProcessBanksFileResponse.java:28: package org.jboss.soa.esb.actions does not exist
      [javac] import org.jboss.soa.esb.actions.AbstractFileAction;
      [javac] ^

      and so on. Last time around I fixed this by moving BaseException.java into the TrailBlazer src folder - but Daniel advises that this should not be necessary.

      Freely admit I might be doing something dumb - perhaps I should move the project to under a "product" directory? Suggestinos and corrections welcomed!

      Thanks

      CMQ

        • 1. Re: Still having Trailblazer problems
          Kurt Stam Master

          Hi CMQ,

          /usr/local/JBossESB_4.0Beta1/docs/samples/trailblazer/bankloanbrokerdemo/product/build/dist/lib not found

          is weird. There is no such path. It should be looking for:

          /usr/local/JBossESB_4.0Beta1/product/docs/samples/trailblazer/bankloanbrokerdemo/build/dist/lib

          Note the position of the product directory! It works for me, so can you double check your *.properties files? Maybe you can post them here if you can't find anything. Make sure, in the product.properties, to leave org.jboss.esb.jboss.home=.

          --Kurt

          • 2. Re: Still having Trailblazer problems
            Chris McQuillan Newbie

            Hi Kurt - thanks for replying

            When I unzip the jbossESB-4.0Beta1-src.zip that I downloaded from http://labs.jboss.com/portal/jbossesb/downloads, no "product" directory exists in the resulting directory tree.

            If I move the unzipped directories into a new "product" subfolder then I get errors at the testJBossESB.sh stage - this worked before - now gets class not found errors, which I can fix by fiddling the classpath etc but it's really moved the problem to a different point in the process.

            I must have a different source tree to what you are using. Any possibility the downlaod I took on the 4th Sep might be screwy?

            CMQ

            • 3. Re: Still having Trailblazer problems
              Kurt Stam Master

              You are right, in the zip file the directory structure is not the same as when you get Beta1 from SVN. This causes the problems that you are seeing. I can reproduce them.

              You can either get check out beta1 from SVN or correct the loanbroker.properties. In the loanbroker properties you will need to set:
              org.jboss.soa.esb.samples.loanbroker.esb_home=../../../../

              (one less ../).

              Make sure you have jarred up your core esb classes before you try to compile the loanbroker classes, as it will look for these jars.

              Hope this helps! Sorry it took so long to figure this out.

              --Kurt

              • 4. Re: Still having Trailblazer problems
                Kurt Stam Master

                oh and fix the loanbroker build.xml by removing three occurrences of the 'product'directory.

                • 5. Re: Still having Trailblazer problems
                  Chris McQuillan Newbie

                  Kurt

                  All sweet now - after several re-installs to clean up the state of play after me trying to fix it the hard way. Many thanks - onto the next phase, actually understanding it and making it work in a real-life scenario.

                  CMQ