12 Replies Latest reply on Apr 17, 2007 5:07 AM by kiran baireddy

    NameNotFoundException InquiryService

    kiran baireddy Newbie

      I am trying to test the helloworld sample in jbossesb.4.0.GA. I have my app deployed in a clustered environment. And the default rmi port is no longer 1099.

      I have changed the helloworld client to point to my port. however, when I run the client, it throws an error " 'NameNotFoundException' InquiryService ".

      I have also tried to check the server for the available JNDI Names. 'The InquiryService name does not exist'.

      However, if I run the sample in a non clustered environment with all the default ports(1099), the app works fine and I can see the 'InquiryService' name in the available JNDI names.

      Could someone please let me know, what I could be doing wrong (OR) is it that ESB does'nt work in a clustered environment. (Though I am running the cluster as a single node in my dev machine).

        • 1. Re: NameNotFoundException InquiryService
          Tom Fennelly Master

          Hi.

          I think you may be the first person to attempt running the ESB on a clustered AS.

          Anyway, can you post back the full stack trace please?

          Also, take a look at this post and see does it help in any way.

          • 2. Re: NameNotFoundException InquiryService
            kiran baireddy Newbie

            Thank you for your response. Here are the stack traces.

            The first one is from the jboss app server. All I am doing here is stopping the jboss server.

            11:55:00,335 INFO [ConfigurationController] Exiting Config Controller...
            11:55:00,335 INFO [JuddiRMIService] Unbinding juddi services
            11:55:00,335 WARN [JuddiRMIService] Stopping failed jboss.org:service=JuddiRMI
            javax.naming.NameNotFoundException: InquiryService not bound
            at org.jnp.server.NamingServer.getBinding(NamingServer.java:529)
            at org.jnp.server.NamingServer.getBinding(NamingServer.java:537)
            at org.jnp.server.NamingServer.unbind(NamingServer.java:242)
            at org.jnp.interfaces.NamingContext.unbind(NamingContext.java:752)
            at org.jnp.interfaces.NamingContext.unbind(NamingContext.java:737)
            at javax.naming.InitialContext.unbind(InitialContext.java:375)
            at org.jboss.internal.soa.esb.dependencies.JuddiRMIService.stopService(J
            uddiRMIService.java:30)
            at org.jboss.system.ServiceMBeanSupport.jbossInternalStop(ServiceMBeanSu
            pport.java:315)
            at org.jboss.system.ServiceMBeanSupport.jbossInternalLifecycle(ServiceMB
            eanSupport.java:247)
            at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
            sorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:585)
            at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatch
            er.java:155)
            at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
            at org.jboss.mx.server.Invocation.invoke(Invocation.java:86)
            at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.
            java:264)


            And the second one is from the esb client while the app server is running.

            [java] Reading config from C:\jbossesb-4.0GA\samples\quickstarts\helloworld
            \jbossesb.xml
            [java] javax.naming.NameNotFoundException: InquiryService
            [java] at org.apache.ws.scout.transport.RMITransport.send(RMITransport.
            java:91)
            [java] at org.apache.ws.scout.registry.RegistryImpl.execute(RegistryImp
            l.java:273)
            [java] at org.apache.ws.scout.registry.RegistryImpl.findService(Registr
            yImpl.java:736)
            [java] at org.apache.ws.scout.registry.BusinessQueryManagerImpl.findSer
            vices(BusinessQueryManagerImpl.java:638)
            [java] at org.jboss.internal.soa.esb.services.registry.JAXRRegistryImpl
            .findService(JAXRRegistryImpl.java:440)
            [java] at org.jboss.internal.soa.esb.services.registry.JAXRRegistryImpl
            .registerEPR(JAXRRegistryImpl.java:173)
            [java] at org.jboss.soa.esb.listeners.RegistryUtil.register(RegistryUti
            l.java:138)
            [java] at org.jboss.soa.esb.listeners.message.MessageAwareListener.doIn
            itialise(MessageAwareListener.java:184)

            • 3. Re: NameNotFoundException InquiryService
              Tom Fennelly Master

              So it looks as though it's failing to connect to the Registry. Can you check the registry connection setting in jbossesb-properties.xml and juddi.properties? Both of these are located in the jbossesb.sar.

              • 4. Re: NameNotFoundException InquiryService
                kiran baireddy Newbie

                Hi, I dont see any config files in jbossesb.sar nor jbossesb-dependencies.sar except for the META-INF\jboss-service.xml.

                However the said property files are in server/<server_name>/conf folder.

                • 5. Re: NameNotFoundException InquiryService
                  Tom Fennelly Master

                  What version of the ESB are you using? Sounds like you're using a pre 4.2MR1 release!

                  • 6. Re: NameNotFoundException InquiryService
                    kiran baireddy Newbie

                    I am using jbossesb-4.0.GA, we use C:\jboss-4.0.5.GA as our app server and thought both of the above go well with each other and both are GA.

                    • 7. Re: NameNotFoundException InquiryService
                      Tom Fennelly Master

                      Is moving to 4.2MR1 an option for you guys? It is *far more* stable than the 4.0GA release - a number of serious issues were resolved in 4.2MR1. Also, the deployment model is a lot cleaner.

                      • 8. Re: NameNotFoundException InquiryService
                        kiran baireddy Newbie

                        Yes any version is possible, since we are still in the hello world stages of ESB. However, that needs to be compatible with 4.0.5.GA. Do you see any compatability issues using 4.2MR1 with 4.0.5.GA app server?

                        • 9. Re: NameNotFoundException InquiryService
                          Tom Fennelly Master

                          Yep, 4.0.5GA is the way to go. ESB v4.2MR1 also offers the option of a standalone ESB Server.

                          • 10. Re: NameNotFoundException InquiryService
                            kiran baireddy Newbie

                            Well, bad news continues, even after switching to jbossesb-4.2MR1, I still get the same exceptions as stated above. In addition.. sometimes I also get the following exception while starting Jboss (after installing esb to jboss).

                            14:59:07,036 INFO [JuddiRMIService] starting juddi RMI service
                            14:59:08,058 INFO [STDOUT] javax.naming.NameAlreadyBoundException
                            14:59:08,058 INFO [STDOUT] at org.jnp.server.NamingServer.bind(NamingServer.
                            java:129)
                            14:59:08,058 INFO [STDOUT] at org.jboss.ha.jndi.TreeHead.bind(TreeHead.java:
                            95)
                            14:59:08,058 INFO [STDOUT] at org.jboss.ha.jndi.HAJNDI.bind(HAJNDI.java:116)

                            14:59:08,058 INFO [STDOUT] at sun.reflect.NativeMethodAccessorImpl.invoke0(N
                            ative Method)
                            14:59:08,058 INFO [STDOUT] at sun.reflect.NativeMethodAccessorImpl.invoke(Na
                            tiveMethodAccessorImpl.java:39)
                            14:59:08,058 INFO [STDOUT] at sun.reflect.DelegatingMethodAccessorImpl.invok
                            e(DelegatingMethodAccessorImpl.java:25)
                            14:59:08,058 INFO [STDOUT] at java.lang.reflect.Method.invoke(Method.java:58
                            5)
                            14:59:08,058 INFO [STDOUT] at org.jboss.ha.framework.server.HARMIServerImpl.
                            invoke(HARMIServerImpl.java:194)

                            • 11. Re: NameNotFoundException InquiryService
                              Kurt Stam Master

                              You seem to be registering the RMI service twice. Maybe once while deploying the juddu.war and once with the jbossesb.sar itself. Try disabling the one in the juddi.war by commenting out that part in the web.xml.

                              • 12. Re: NameNotFoundException InquiryService
                                kiran baireddy Newbie

                                I dont have a juddi.war, is it something that I should have? Could you please let me know where I can find it. All I did was was installed esb to App server and it generated the jobssesb.sar folder and it does'nt contain the juddi.war file in it.