6 Replies Latest reply on Jul 20, 2007 2:54 AM by Fred Mac

    impossible to deploy the ESB console in JBoss 4.2.1 and JBos

    Fred Mac Newbie

      Hi all,

      when trying to deploy the jboss-esb-console.ear (built with ant from JbossESB 4.2MR2) in JbossAS, I got the following pbs (I tried with 4.2.1 and 4.0.5GA)

      in 4.2.1 I met the known pb with myfaces that disappeared in 4.2.1. I found an issue http://lists.jboss.org/pipermail/esb-issues/2007-June/001111.html on that subject in JIRA : the status is closed and solved ...but I could not find any concrete solution or fix !

      So I tried to deply it to JbossAS 4.0.5GA, and then I got :

      15:02:16,188 INFO [EARDeployer] Init J2EE application: file:/D:/j2ee/jboss-4.0.5.GA/server/default/deploy/jboss-esb-console.ear
      15:02:22,857 ERROR [MainDeployer] Could not create deployment: file:/D:/j2ee/jboss-4.0.5.GA/server/default/tmp/deploy/tmp63090jboss-esb-console.ear-contents/jboss-esb-console.jar
      org.jboss.deployment.DeploymentException: ejb-jar.xml must either obey the right xml schema or define a valid DOCTYPE!
      at org.jboss.metadata.ApplicationMetaData.importEjbJarXml(ApplicationMet
      aData.java:339)
      at org.jboss.metadata.XmlFileLoader.load(XmlFileLoader.java:166)
      at org.jboss.ejb.EJBDeployer.create(EJBDeployer.java:541)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25) [...]


      If someone succeeded in deploying this console, I'm interested to know how and the different versions (for JBOssESB and JBossAS).

      Thanks !

      Fred