2 Replies Latest reply on Aug 7, 2007 4:57 PM by amine mrad

    problem with webservice_producer quickstart

    amine mrad Newbie

      Hello,
      I am trying to run the webservice_quickstart sample but when i type ant runtest after the deployment i get the following error

      saygoodbye_over_http:
      [echo] Invoking a JBossWS Endpoint over HTTP (via JBoss ESB).
      [java] Calling JBoss Remoting Listener using locator URI: http://localhost:
      8765
      [java] Exception in thread "main" org.jboss.remoting.CannotConnectException
      : Can not connect http client invoker.
      [java] at org.jboss.remoting.transport.http.HTTPClientInvoker.useHttpUR
      LConnection(HTTPClientInvoker.java:201)
      [java] at org.jboss.remoting.transport.http.HTTPClientInvoker.transport
      (HTTPClientInvoker.java:81)
      [java] at org.jboss.remoting.RemoteClientInvoker.invoke(RemoteClientInv
      oker.java:143)
      [java] at org.jboss.remoting.Client.invoke(Client.java:525)
      [java] at org.jboss.remoting.Client.invoke(Client.java:488)
      [java] at org.jboss.remoting.Client.invoke(Client.java:473)
      [java] at org.jboss.soa.esb.samples.quickstart.webserviceproducer.test.
      SendMessage.sendMessageToJBRListener(SendMessage.java:72)
      [java] at org.jboss.soa.esb.samples.quickstart.webserviceproducer.test.
      SendMessage.main(SendMessage.java:113)
      [java] Caused by: java.net.ConnectException: Connection refused: connect
      [java] at java.net.PlainSocketImpl.socketConnect(Native Method)
      [java] at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
      [java] at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.jav
      a:195)
      [java] at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
      [java] at java.net.Socket.connect(Socket.java:519)
      [java] at java.net.Socket.connect(Socket.java:469)
      [java] at sun.net.NetworkClient.doConnect(NetworkClient.java:157)
      [java] at sun.net.www.http.HttpClient.openServer(HttpClient.java:382)
      [java] at sun.net.www.http.HttpClient.openServer(HttpClient.java:509)
      [java] at sun.net.www.http.HttpClient.(HttpClient.java:231)
      [java] at sun.net.www.http.HttpClient.New(HttpClient.java:304)
      [java] at sun.net.www.http.HttpClient.New(HttpClient.java:316)
      [java] at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(
      HttpURLConnection.java:813)
      [java] at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Http
      URLConnection.java:765)
      [java] at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLCo
      nnection.java:690)
      [java] at sun.net.www.protocol.http.HttpURLConnection.getOutputStream(H
      ttpURLConnection.java:857)
      [java] at org.jboss.remoting.transport.http.HTTPClientInvoker.useHttpUR
      LConnection(HTTPClientInvoker.java:163)
      [java] ... 7 more

      BUILD FAILED
      C:\Stage_jboss\jbossesb-4.2MR3\samples\quickstarts\webservice_producer\build.xml
      :32: The following error occurred while executing this line:
      C:\Stage_jboss\jbossesb-4.2MR3\samples\quickstarts\webservice_producer\build.xml
      :46: Java returned: 1

      have someone faced this problem before?

      m_rad