2 Replies Latest reply on Oct 23, 2007 4:55 AM by fabianw

    Problems deploying JBoss ESB to AS

    fabianw Newbie

      Hi there

      I'm writing my master thesis about service-oriented architectures. As part of this thesis I want to implement a business-process using JBoss software, but I'm having some problems at configuring the whole environment. I want to use JBoss AS 4.2.1 + JBoss ESB 4.2. + ActiveBPEL + Red Hat Developer Studio.
      I've already installed AS, but I'm not able to deploy the ESB to the AS. Ant fails with:
      BUILD FAILED
      C:\jbossesb-4.2GA\install\build.xml:64: Could not determine JMS provider

      I took a look at the build.xml and it seems to check if JBoss Messaging is available. I deployed JBoss Messaging to the AS and used the 'messaging' profile for the ESB, but I still get the same error.
      Why is that? - any help is greatly appreciated!

      By the way... I already downloaded and installed the RH Developer Studio. If I understand correctly it already contains an JBoss AS, but i want to use my separate AS installation. How can I configure the Developer Studio to use the other installation?