6 Replies Latest reply on Dec 11, 2007 12:15 PM by Miguel Angel Goicochea

    Problem when trying to install JBoss ESB in JBoss AS

    Miguel Angel Goicochea Newbie

      Both are versions 4.2.1 and I'm using ant 1.7

      This is my deploy.properties file on the ESB



      ######################################################################
      # JBossESB ant deployment properties file
      #
      # Copy the example file and replace with your values
      #
      ######################################################################
      
      ######################################################################
      # You can use three deployment options: deploy to JBossAS, Tomcat or
      # create a standalone launcher, so you probably only care about
      # one of the following sections.
      ######################################################################
      # JBossAS
      ######################################################################
      # The Directory in Which JBoss AS is Installed
      # The absolute path to a directory in which a version of JBoss AS with
      # EJB3 has been installed.
      # This path should not include spaces.
      # Use of relative paths or paths with spaces will cause runtime errors
      # when deploying and executing the quickstart and the trailblazers.
      # (e.g. /home/pbennett/jboss-4.0.5.GA-ejb3)
      # (By default the 'ant install' task will create this directory.)
      org.jboss.esb.server.home=D:\SOATools\jbossesb-4.2.1GA
      # The Configuration of JBoss AS to Use
      # (e.g. default)
      org.jboss.esb.server.config=default





      and this is what I get when I try to install it


      ERROR:......


      Buildfile: build.xml

      check.deploy.props:

      dependencies.source:

      dependencies.jbossesb:

      dependencies:

      jms.config.check:

      BUILD FAILED
      D:\SOATools\jbossesb-4.2.1GA\install\build.xml:67: Could not determine JMS provi
      der



        • 1. Re: Problem when trying to install JBoss ESB in JBoss AS
          Kevin Conner Master

           

          "magoicochea" wrote:

          # The Directory in Which JBoss AS is Installed
          
          org.jboss.esb.server.home=D:\SOATools\jbossesb-4.2.1GA


          You need to configure the above property correctly, see comment.


          • 2. Re: Problem when trying to install JBoss ESB in JBoss AS
            Miguel Angel Goicochea Newbie

            Sorry I overlooked that thing, but now I have this on the deployment.properties and the problem is still the same

            ######################################################################
            # JBossESB ant deployment properties file
            #
            # Copy the example file and replace with your values
            #
            ######################################################################
            
            ######################################################################
            # You can use three deployment options: deploy to JBossAS, Tomcat or
            # create a standalone launcher, so you probably only care about
            # one of the following sections.
            ######################################################################
            # JBossAS
            ######################################################################
            # The Directory in Which JBoss AS is Installed
            # The absolute path to a directory in which a version of JBoss AS with
            # EJB3 has been installed.
            # This path should not include spaces.
            # Use of relative paths or paths with spaces will cause runtime errors
            # when deploying and executing the quickstart and the trailblazers.
            # (e.g. /home/pbennett/jboss-4.0.5.GA-ejb3)
            # (By default the 'ant install' task will create this directory.)
            org.jboss.esb.server.home=D:\SOATools\jboss-4.2.1.GA
            # The Configuration of JBoss AS to Use
            # (e.g. default)
            org.jboss.esb.server.config=default
            
            


            • 3. Re: Problem when trying to install JBoss ESB in JBoss AS
              Kevin Conner Master

              In that case try the following
              - run 'ant -v deploy'

              If it fails then the debugging output should show you what is happening.

              You should also be using ant 1.6.5 as that is the version we support. We already know about certain parts of the build scripts that do not work under 1.7.0.

              • 4. Re: Problem when trying to install JBoss ESB in JBoss AS
                Miguel Angel Goicochea Newbie

                OK here is the output:

                D:\SOATools\jbossesb-4.2.1GA\install>ant -v deploy
                Apache Ant version 1.7.0 compiled on December 13 2006
                Buildfile: build.xml
                Detected Java version: 1.5 in: C:\Program Files\Java\jdk1.5.0_14\jre
                Detected OS: Windows 2000
                parsing buildfile D:\SOATools\jbossesb-4.2.1GA\install\build.xml with URI = file
                :/D:/SOATools/jbossesb-4.2.1GA/install/build.xml
                Project base dir set to: D:\SOATools\jbossesb-4.2.1GA\install
                [antlib:org.apache.tools.ant] Could not load definitions from resource org/apach
                e/tools/ant/antlib.xml. It could not be found.
                 [property] Loading D:\SOATools\jbossesb-4.2.1GA\install\deployment.properties
                [available] Unable to find D:\SOATools\jbossesb-4.2.1GA\build-distr.xml
                [available] Found: D:\SOATools\jbossesb-4.2.1GA\JBossORG-EULA.txt
                Property "org.jboss.esb.tomcat.home" has not been set
                Property "org.jboss.esb.tomcat.home" has not been set
                [available] Unable to find ${org.jboss.esb.tomcat.home}\common\lib to set proper
                ty org.jboss.esb.tomcat.lib
                [available] Unable to find ${org.jboss.esb.tomcat.home}\lib to set property org.
                jboss.esb.tomcat.lib
                Property "org.jboss.esb.dist.lib" has not been set
                Property "org.jboss.esb.tomcat.lib" has not been set
                Build sequence for target(s) `deploy' is [check.deploy.props, dependencies.sourc
                e, dependencies.jbossesb, dependencies, jms.config.check, jbmq.config, jbm.confi
                g, jms.config, internal.deploy, init.bindings.props, deploy.bindings, deploy]
                Complete build sequence is [check.deploy.props, dependencies.source, dependencie
                s.jbossesb, dependencies, jms.config.check, jbmq.config, jbm.config, jms.config,
                 internal.deploy, init.bindings.props, deploy.bindings, deploy, undeploy.binding
                s, undeploy, apply-jbossws-xslt, check.tomcat.props, tomcat.compile, tomcat.war.
                all.deploy, tomcat, patch-jbossws, deployIntros, ]
                
                check.deploy.props:
                
                dependencies.source:
                Skipped because property 'hierarchy.source' not set.
                
                dependencies.jbossesb:
                
                dependencies:
                
                jms.config.check:
                [available] Unable to find SOAToolsjboss-4.2.1.GA\server\default\deploy\jboss-me
                ssaging to set property jbm.present
                [available] Unable to find SOAToolsjboss-4.2.1.GA\server\default\deploy\jboss-me
                ssaging.sar to set property jbm.present
                [available] Unable to find SOAToolsjboss-4.2.1.GA\server\default\deploy\jms\jbos
                smq-service.xml to set property jbmq.present
                [available] Unable to find SOAToolsjboss-4.2.1.GA\server\default\deploy-hasingle
                ton\jms\jbossmq-service.xml to set property jbmq.present
                
                BUILD FAILED
                D:\SOATools\jbossesb-4.2.1GA\install\build.xml:67: Could not determine JMS provi
                der
                 at org.apache.tools.ant.taskdefs.Exit.execute(Exit.java:142)
                 at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
                 at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
                 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
                sorImpl.java:25)
                 at java.lang.reflect.Method.invoke(Method.java:585)
                 at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.jav
                a:105)
                 at org.apache.tools.ant.Task.perform(Task.java:348)
                 at org.apache.tools.ant.Target.execute(Target.java:357)
                 at org.apache.tools.ant.Target.performTasks(Target.java:385)
                 at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
                 at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
                 at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExe
                cutor.java:41)
                 at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
                 at org.apache.tools.ant.Main.runBuild(Main.java:698)
                 at org.apache.tools.ant.Main.startAnt(Main.java:199)
                 at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
                 at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
                
                Total time: 0 seconds
                D:\SOATools\jbossesb-4.2.1GA\install>
                


                • 5. Re: Problem when trying to install JBoss ESB in JBoss AS
                  Kevin Conner Master

                   

                  "magoicochea" wrote:
                  jms.config.check:
                  [available] Unable to find SOAToolsjboss-4.2.1.GA\server\default\deploy\jboss-me
                  ssaging to set property jbm.present
                  [available] Unable to find SOAToolsjboss-4.2.1.GA\server\default\deploy\jboss-me
                  ssaging.sar to set property jbm.present
                  [available] Unable to find SOAToolsjboss-4.2.1.GA\server\default\deploy\jms\jbos
                  smq-service.xml to set property jbmq.present
                  [available] Unable to find SOAToolsjboss-4.2.1.GA\server\default\deploy-hasingle
                  ton\jms\jbossmq-service.xml to set property jbmq.present

                  Okay, it looks like the windows directory has been escaped.

                  Try setting the AS directory to /D:/SOATools/jboss-4.2.1GA


                  • 6. Re: Problem when trying to install JBoss ESB in JBoss AS
                    Miguel Angel Goicochea Newbie

                    Yes that solved the problem, I hope that everything will be fine now.

                    Thank you very much