1 Reply Latest reply on Jan 30, 2008 12:28 AM by Edgar Silva

    Getting an Exception trying deliver a message

    Edgar Silva Newbie

      Hi Folks,

      I tried publish a message with some info in header and body of this message, in the client tier I am using the ServiceInvoker to publish a message using the synch method.

      When I try publish a simple message, the action is activated, however when I try publish a not so simple message, the following exception is happening:

      Failed to deliver message [header: [ To: JMSEpr [ PortReference < <wsa:Address jms://localhost/queue/SeatManagerQueue_response/>, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : 1/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/jms/> > ] MessageID: 1234 ]] to Service [JBossESB-Internal:DeadLetterService]. Check for errors. at org.jboss.soa.esb.client.ServiceInvoker.post(ServiceInvoker.java:279)

      I googled about it, and I found some JIRA issues, is it a known problem, or is there any other way to solve it?

      Tks in Advance

      Edgar

        • 1. Re: Getting an Exception trying deliver a message
          Edgar Silva Newbie

          Hey folks,

          I've been using a POJO provided by my customer, where this one does not implemented java.io.Serializable, so when I tried the following code:


          Reserva res = new ReservaServico().
          executa(ReservaServico.RESERVA).
          numeroDaReserva("EDJDSK").
          queOVooSeja("JJ2212").
          noAssento("14E").
          getReserva();

          esbMessage.getHeader().getCall().setMessageID(new URI("98982232321"));
          esbMessage.getBody().add("acao",Contants.RESERVA_CODE);
          esbMessage.getBody().add("reserva",res);


          In the "reserva" a had a reference for a non-serializeable object, that is why the exception was occurring here. So just, keep in mind about "Serializable issues" when you are working with sources that you are not the owner =)