9 Replies Latest reply on Apr 4, 2008 11:08 AM by Tom Fennelly

    Help Needed Urgently to configure jbr provider

    Puneet Jain Newbie

      Hi,

      We are in the process of evaluating the features and performance of Jbossesb.
      We have written an application which has a jbr-provider.
      It prints the input message on the console.
      While We tried to run the sample We got exception. Exception details is attached below:

      The Jboss-esb.xml is given below:

      <?xml version = "1.0" encoding = "UTF-8"?>
      <jbossesb
       xmlns="http://anonsvn.labs.jboss.com/labs/jbossesb/trunk/product/etc/schemas/xml/jbossesb-1.0.1.xsd"
       parameterReloadSecs="5">
      
       <providers>
       <jbr-provider name="JBR-Http" protocol="http" host="localhost">
       <jbr-bus busid="Http-1" port="8765" />
       </jbr-provider>
       </providers>
      
       <services>
       <service category="SampleCategory" name="Sample" description="WS Frontend speaks natively to the ESB">
       <listeners>
       <jbr-listener name="Http-Gateway" busidref="Http-1" is-gateway="true" maxThreads="1"/>
       </listeners>
       <actions>
       <action name="print-before" class="org.jboss.soa.esb.actions.SystemPrintln">
       <property name="message"
       value="BEFORE invoking jbossws endpoint***************************"/>
       </action>
       </service>
       </services>
      </jbossesb>
      
      


      Environment:
      ========
      Jbossesb-4.2.1GA
      Jboss Application Server 4.2.2.GA
      OS: Redhat Enterprise Linux 4


      Exception Raised:
      ===========
      run:
       [echo] esb.config.file >>>> ${esb.config.file}
       [echo] esb.config.file >>>> D:\OKISoft\JbossESB\17Mar2008\jbossesb-4.2.1GA\samples\quickstarts\perfsample/jboss-esb.xml
       [echo] Launching Quickstart in standalone mode...
       [qsjava] +----------------------------------------------------------+
       [qsjava] | |
       [qsjava] | Starting JBossESB... |
       [qsjava] | |
       [qsjava] +----------------------------------------------------------+
       [qsjava] Reading config from D:\OKISoft\JbossESB\17Mar2008\jbossesb-4.2.1GA\samples\quickstarts\perfsample\jboss-esb.xml
       [qsjava] 17:15:08,056 FATAL [main][XmlValidatorImpl] FATAL-null-22:The element type "actions" must be terminated by the matching end-tag "</actions>".
       [qsjava] 17:15:08,056 ERROR [main][XmlValidatorImpl] SAXException occurred: The element type "actions" must be terminated by the matching end-tag "</actions>".
       [qsjava] 17:15:08,056 ERROR [main][ConfigurationController] The configuration file D:\OKISoft\JbossESB\17Mar2008\jbossesb-4.2.1GA\samples\quickstarts\perfsample\jboss-esb.xml
       [qsjava] did not pass validation for the following reasons:
       [qsjava] ** 1. FATAL-null-22:The element type "actions" must be terminated by the matching end-tag "</actions>".
       [qsjava]
       [qsjava] Exception in thread "main" org.jboss.soa.esb.ConfigurationException: Unable to generate gateway and listener configurations
       [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.initiateController(StandAloneBootStrapper.java:227)
       [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.<init>(StandAloneBootStrapper.java:154)
       [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.<init>(StandAloneBootStrapper.java:130)
       [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.main(StandAloneBootStrapper.java:97)
      
      


      Please help me to resolve the issue and provide us some pointers/links to configure jbr-provider.

      Any reply will be appreciated.

      Thanks in Advance.
      Puneet


        • 1. Re: Help Needed Urgently to configure jbr provider
          Daniel Bevenius Master

           


          The element type "actions" must be terminated by the matching end-tag "</actions>".

          Just add a closing actions tag:
          <actions>
           <action name="print-before" class="org.jboss.soa.esb.actions.SystemPrintln">
           <property name="message"
           value="BEFORE invoking jbossws endpoint***************************"/>
           </action>
          </actions>
          


          Regards,

          Daniel

          • 2. Re: Help Needed Urgently to configure jbr provider
            Puneet Jain Newbie

            Hi,

            Sorry for the previous mail.
            Thanks for the quick reply.

            I have rectify the xml file and tried to run.

            But the Exception has raised:

            run:
             [echo] esb.config.file >>>> ${esb.config.file}
             [echo] esb.config.file >>>> D:\OKISoft\JbossESB\17Mar2008\jbossesb-4.2.1GA\samples\quickstarts\perfsample/jboss-esb.xml
             [echo] Launching Quickstart in standalone mode...
             [qsjava] +----------------------------------------------------------+
             [qsjava] | |
             [qsjava] | Starting JBossESB... |
             [qsjava] | |
             [qsjava] +----------------------------------------------------------+
             [qsjava] Reading config from D:\OKISoft\JbossESB\17Mar2008\jbossesb-4.2.1GA\samples\quickstarts\perfsample\jboss-esb.xml
             [qsjava] 17:34:14,851 ERROR [main][ConfigurationController] The current versions of the jbossesb-listener.xml and/or jbossesb-gateway.xml are kept in place until the error is resolved: Service configuration for Service 'SampleCategory:Sample' doesn't define a Message-Aware Listener (i.e. is-gateway='false').
             [qsjava] org.jboss.soa.esb.ConfigurationException: Service configuration for Service 'SampleCategory:Sample' doesn't define a Message-Aware Listener (i.e. is-gateway='false').
             [qsjava] at org.jboss.soa.esb.listeners.config.Generator$XMLBeansModel.getListeners(Generator.java:377)
             [qsjava] at org.jboss.soa.esb.listeners.config.Generator$XMLBeansModel.getESBAwareListeners(Generator.java:250)
             [qsjava] at org.jboss.soa.esb.listeners.config.ESBAwareGenerator.generate(ESBAwareGenerator.java:83)
             [qsjava] at org.jboss.soa.esb.listeners.config.Generator.generate(Generator.java:184)
             [qsjava] at org.jboss.soa.esb.listeners.config.ConfigurationController.processConfiguration(ConfigurationController.java:322)
             [qsjava] at org.jboss.soa.esb.listeners.config.ConfigurationController.<init>(ConfigurationController.java:128)
             [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.initiateController(StandAloneBootStrapper.java:219)
             [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.<init>(StandAloneBootStrapper.java:154)
             [qsjava] Exception in thread "main" org.jboss.soa.esb.ConfigurationException: Unable to generate gateway and listener configurations
             [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.initiateController(StandAloneBootStrapper.java:227)
             [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.<init>(StandAloneBootStrapper.java:154)
             [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.<init>(StandAloneBootStrapper.java:130)
             [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.main(StandAloneBootStrapper.java:97)
             [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.<init>(StandAloneBootStrapper.java:130)
             [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.main(StandAloneBootStrapper.java:97)
            
            




            • 3. Re: Help Needed Urgently to configure jbr provider
              Daniel Bevenius Master

              You'll need to configure a listener aswell as a gateway.

              For example:

              <services>
               <service category="SampleCategory" name="Sample" description="WS Frontend speaks natively to the ESB">
               <listeners>
               <jbr-listener name="Http-Gateway" busidref="Http-1" is-gateway="true" maxThreads="1"/>
               <jms-listener name="JMS-ESBListener" busidref="quickstartEsbChannel" maxThreads="1"/>
               </listeners>
               <actions>
               <action name="print-before" class="org.jboss.soa.esb.actions.SystemPrintln">
               <property name="message"
               value="BEFORE invoking jbossws endpoint***************************"/>
               </action>
               </service>
               </services>
              

              Have a look at the webservice_producer example a working example of this.

              Regards,

              Daniel

              • 4. Re: Help Needed Urgently to configure jbr provider
                Puneet Jain Newbie

                Hi,

                Thanks for your reply. Your Inputs are very valuable to me.

                I tried with the configuration specified by you.
                I got following exceptions

                I have one more question regarding JBossesb that I my requirement is to invoke a servlet from the action. Is there any action pre defined action available to invoke a servlet from jbossesb? How can I invoke a servlet from Jbossesb?

                run:
                 [echo] esb.config.file >>>> ${esb.config.file}
                 [echo] esb.config.file >>>> D:\OKISoft\JbossESB\17Mar2008\jbossesb-4.2.1GA\samples\quickstarts\perfsample/jboss-esb.xml
                 [echo] Launching Quickstart in standalone mode...
                 [qsjava] +----------------------------------------------------------+
                 [qsjava] | |
                 [qsjava] | Starting JBossESB... |
                 [qsjava] | |
                 [qsjava] +----------------------------------------------------------+
                 [qsjava] Reading config from D:\OKISoft\JbossESB\17Mar2008\jbossesb-4.2.1GA\samples\quickstarts\perfsample\jboss-esb.xml
                 [qsjava] 18:04:58,191 INFO [main][SimpleThreadPool] Job execution threads will use class loader of thread: main
                 [qsjava] 18:04:58,238 INFO [main][QuartzScheduler] Quartz Scheduler v.1.5.2 created.
                 [qsjava] 18:04:58,253 INFO [main][RAMJobStore] RAMJobStore initialized.
                 [qsjava] 18:04:58,253 INFO [main][StdSchedulerFactory] Quartz scheduler 'DefaultQuartzScheduler' initialized from an externally provided properties instance.
                 [qsjava] 18:04:58,253 INFO [main][StdSchedulerFactory] Quartz scheduler version: 1.5.2
                 [qsjava] java.lang.NullPointerException
                 [qsjava] at java.lang.Class.forName0(Native Method)
                 [qsjava] at java.lang.Class.forName(Class.java:242)
                 [qsjava] at org.jboss.soa.esb.util.ClassUtil.forName(ClassUtil.java:65)
                 [qsjava] at org.jboss.soa.esb.services.registry.RegistryFactory.createRegistry(RegistryFactory.java:64)
                 [qsjava] at org.jboss.soa.esb.services.registry.RegistryFactory.getRegistry(RegistryFactory.java:51)
                 [qsjava] at org.jboss.soa.esb.listeners.RegistryUtil.register(RegistryUtil.java:129)
                 [qsjava] at org.jboss.soa.esb.listeners.message.MessageAwareListener.doInitialise(MessageAwareListener.java:213)
                 [qsjava] at org.jboss.soa.esb.listeners.lifecycle.AbstractManagedLifecycle.initialise(AbstractManagedLifecycle.java:133)
                 [qsjava] at org.jboss.soa.esb.listeners.lifecycle.ManagedLifecycleController.initialiseInstances(ManagedLifecycleController.java:150)
                 [qsjava] at org.jboss.soa.esb.listeners.lifecycle.ManagedLifecycleController.start(ManagedLifecycleController.java:69)
                 [qsjava] at org.jboss.soa.esb.listeners.config.ConfigurationController.startController(ConfigurationController.java:366)
                 [qsjava] at org.jboss.soa.esb.listeners.config.ConfigurationController.startController(ConfigurationController.java:354)
                 [qsjava] at org.jboss.soa.esb.listeners.config.ConfigurationController.processConfiguration(ConfigurationController.java:328)
                 [qsjava] 18:04:58,363 ERROR [main][ConfigurationController] Unexpected exception starting controller
                 [qsjava] org.jboss.soa.esb.listeners.lifecycle.ManagedLifecycleException: Unexpected error during registration for epr JMSEpr [ PortReference < <wsa:Address jms://localhost/queue/quickstart_sample_esb/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : localhost/>, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:specification-ve
                rsion : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : 1/> > ]
                 [qsjava] at org.jboss.soa.esb.listeners.message.MessageAwareListener.doInitialise(MessageAwareListener.java:218)
                 [qsjava] at org.jboss.soa.esb.listeners.lifecycle.AbstractManagedLifecycle.initialise(AbstractManagedLifecycle.java:133)
                 [qsjava] at org.jboss.soa.esb.listeners.lifecycle.ManagedLifecycleController.initialiseInstances(ManagedLifecycleController.java:150)
                 [qsjava] at org.jboss.soa.esb.listeners.lifecycle.ManagedLifecycleController.start(ManagedLifecycleController.java:69)
                 [qsjava] at org.jboss.soa.esb.listeners.config.ConfigurationController.startController(ConfigurationController.java:366)
                 [qsjava] at org.jboss.soa.esb.listeners.config.ConfigurationController.startController(ConfigurationController.java:354)
                 [qsjava] at org.jboss.soa.esb.listeners.config.ConfigurationController.processConfiguration(ConfigurationController.java:328)
                 [qsjava] at org.jboss.soa.esb.listeners.config.ConfigurationController.<init>(ConfigurationController.java:128)
                 [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.initiateController(StandAloneBootStrapper.java:219)
                 [qsjava] at org.jboss.soa.esb.listeners.config.ConfigurationController.<init>(ConfigurationController.java:128)
                 [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.initiateController(StandAloneBootStrapper.java:219)
                 [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.<init>(StandAloneBootStrapper.java:154)
                 [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.<init>(StandAloneBootStrapper.java:130)
                 [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.main(StandAloneBootStrapper.java:97)
                 [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.<init>(StandAloneBootStrapper.java:154)
                 [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.<init>(StandAloneBootStrapper.java:130)
                 [qsjava] at org.jboss.soa.esb.listeners.StandAloneBootStrapper.main(StandAloneBootStrapper.java:97)
                 [qsjava] Caused by: org.jboss.soa.esb.services.registry.RegistryException: Invocation exception. null
                 [qsjava] at org.jboss.soa.esb.services.registry.RegistryFactory.createRegistry(RegistryFactory.java:77)
                 [qsjava] at org.jboss.soa.esb.services.registry.RegistryFactory.getRegistry(RegistryFactory.java:51)
                 [qsjava] at org.jboss.soa.esb.listeners.RegistryUtil.register(RegistryUtil.java:129)
                 [qsjava] at org.jboss.soa.esb.listeners.message.MessageAwareListener.doInitialise(MessageAwareListener.java:213)
                 [qsjava] ... 11 more
                 [qsjava] Caused by: java.lang.NullPointerException
                 [qsjava] at java.lang.Class.forName0(Native Method)
                 [qsjava] at java.lang.Class.forName(Class.java:242)
                 [qsjava] at org.jboss.soa.esb.util.ClassUtil.forName(ClassUtil.java:65)
                 [qsjava] at org.jboss.soa.esb.services.registry.RegistryFactory.createRegistry(RegistryFactory.java:64)
                 [qsjava] ... 14 more
                



                Thanks,
                Puneet

                • 5. Re: Help Needed Urgently to configure jbr provider
                  Daniel Bevenius Master

                  Did you add the jms-provider configuration aswell?

                  There is a HttpRouter action that you might be able to use:

                  <action class="org.jboss.soa.esb.actions.routing.HttpRouter">
                   <property name="routeUrl" value="http://localhost:8888"</property>
                  </action>


                  Regards,

                  Daniel

                  • 6. Re: Help Needed Urgently to configure jbr provider
                    Puneet Jain Newbie

                    Hi beve,

                    Thanks for your valuable inputs. I realy appreciate your support.
                    Yes I have added the jms-provider configuration in jboss-esb.xml.

                    <?xml version = "1.0" encoding = "UTF-8"?>
                    <jbossesb
                     xmlns="http://anonsvn.labs.jboss.com/labs/jbossesb/trunk/product/etc/schemas/xml/jbossesb-1.0.1.xsd"
                     parameterReloadSecs="5">
                    
                     <providers>
                     <jms-provider name="JBossMQ" connection-factory="ConnectionFactory"
                     jndi-context-factory="org.jnp.interfaces.NamingContextFactory"
                     jndi-URL="localhost">
                    
                     <jms-bus busid="sampleEsbChannel">
                     <jms-message-filter dest-type="QUEUE" dest-name="queue/quickstart_sample_esb"/>
                     </jms-bus>
                     </jms-provider>
                    
                     <jbr-provider name="JBR-Http" protocol="http" host="localhost">
                     <jbr-bus busid="Http-1" port="8765" />
                     </jbr-provider>
                     </providers>
                    
                    
                    <services>
                     <service category="SampleCategory" name="Sample" description="WS Frontend speaks natively to the ESB">
                     <listeners>
                     <jbr-listener name="Http-Gateway" busidref="Http-1" is-gateway="true" maxThreads="1"/>
                     <jms-listener name="JMS-ESBListener" busidref="sampleEsbChannel" maxThreads="1"/>
                     </listeners>
                     <actions>
                     <action name="Route" class="org.jboss.soa.esb.actions.routing.HttpRouter">
                     <property name="routeUrl" value="http://localhost:8080"></property>
                     </action>
                     </actions>
                     </service>
                     </services>
                    
                    </jbossesb>
                    


                    I have deployed the sample .esb package to JBoss and tried to access the application using browser (http://localhost:8765).

                    But its not working fine. I got following Exception:

                    18:39:13,891 INFO [JBoss4ESBDeployer] create esb service, PerfTester.esb
                    18:39:14,172 INFO [JDBCDataStore] Generated token 'authToken:52D27CD0-0248-11DD-BCD2-C819B54E5E67' for user: 'jbossesb/JBoss ESB User'
                    18:39:14,547 INFO [CoyoteInvoker] Using org.apache.coyote.http11.Http11Protocol for http (coyote) invoker protocol handler.
                    18:39:14,563 INFO [Http11Protocol] Initializing Coyote HTTP/1.1 on http-localhost%2F127.0.0.1-8765
                    18:39:14,563 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-localhost%2F127.0.0.1-8765
                    18:39:14,579 INFO [JBossRemotingGatewayListener] JBoss Remoting Gateway listener 'Http-Gateway' started.
                    18:39:14,657 INFO [JDBCDataStore] Generated token 'authToken:53213910-0248-11DD-BCD2-CBED48141B0B' for user: 'jbossesb/JBoss ESB User'
                    18:39:14,923 INFO [QuartzScheduler] Scheduler DefaultQuartzScheduler_$_NON_CLUSTERED started.
                    18:39:15,907 WARN [MessageAwareListener] Error processing courier, backing off for 1000 milliseconds
                    18:39:17,940 WARN [MessageAwareListener] Error processing courier, backing off for 2000 milliseconds
                    18:39:20,972 WARN [MessageAwareListener] Error processing courier, backing off for 4000 milliseconds
                    18:39:26,006 WARN [MessageAwareListener] Error processing courier, backing off for 8000 milliseconds
                    18:39:35,042 WARN [MessageAwareListener] Error processing courier, backing off for 16000 milliseconds
                    18:39:44,765 INFO [MessagePayloadProxy] Setting null data in message location(s): [org.jboss.soa.esb.message.defaultEntry]
                    18:39:44,828 INFO [ServiceInvoker] Unresponsive EPR: JMSEpr [ PortReference < <wsa:Address jms://localhost/queue/quickstart_sample_esb/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : localhost/>, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory
                    : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : 1/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/jms/> > ] for message: header: [ To: JMSEpr [ PortReference < <wsa:Address jms://localhost/queue/quickstart_sample_esb/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : localhost/
                    >, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : 1/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/jms/> > ] ReplyTo: JMSEpr [ PortReference < <wsa:Address jms://localhost/queue/quickstart_sample_esb_reply/>, <wsa:Re
                    ferenceProperties jbossesb:java.naming.provider.url : localhost/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:message-selector : jbossESBresponseUUID='ef2008c0-b69b-4cd0-ad0d-21877b2b1607'/>, <wsa:Re
                    ferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : 1/> > ] ]
                    18:39:44,953 INFO [ServiceInvoker] Unresponsive EPR: JMSEpr [ PortReference < <wsa:Address jms://localhost/queue/quickstart_sample_esb/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : localhost/>, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory
                    : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : 1/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/jms/> > ] for message: header: [ To: JMSEpr [ PortReference < <wsa:Address jms://localhost/queue/quickstart_sample_esb/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : localhost/
                    >, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : 1/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/jms/> > ] ReplyTo: JMSEpr [ PortReference < <wsa:Address jms://localhost/queue/quickstart_sample_esb_reply/>, <wsa:Re
                    ferenceProperties jbossesb:java.naming.provider.url : localhost/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:message-selector : jbossESBresponseUUID='ef2008c0-b69b-4cd0-ad0d-21877b2b1607'/>, <wsa:Re
                    ferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : 1/> > ] ]
                    18:39:44,969 WARN [ServiceInvoker] Badly formed EPR [EPR: PortReference < <wsa:Address http://localhost:8765/> >] for Service [SampleCategory:Sample] and Message [header: [ To: JMSEpr [ PortReference < <wsa:Address jms://localhost/queue/quickstart_sample_esb/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : localhost/>, <wsa:ReferenceProperties jbossesb:destination-type : que
                    ue/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : 1/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/jms/> > ] ReplyTo: JMSEpr [ PortReference < <wsa:Address jms://localhost/queue/quickstart_sample_esb_reply/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : local
                    host/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:message-selector : jbossESBresponseUUID='ef2008c0-b69b-4cd0-ad0d-21877b2b1607'/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:Refere
                    nceProperties jbossesb:acknowledge-mode : 1/> > ] ]].Courier for EPR not supported!
                    18:39:44,984 INFO [ServiceInvoker] Invalid EPR for service: ignoring for message: header: [ To: JMSEpr [ PortReference < <wsa:Address jms://localhost/queue/quickstart_sample_esb/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : localhost/>, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:Refer
                    enceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : 1/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/jms/> > ] ReplyTo: JMSEpr [ PortReference < <wsa:Address jms://localhost/queue/quickstart_sample_esb_reply/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : localhost/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.i
                    nterfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:message-selector : jbossESBresponseUUID='ef2008c0-b69b-4cd0-ad0d-21877b2b1607'/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : 1/> > ] ]
                    18:39:45,015 INFO [ServiceInvoker] Delivering message [header: [ To: JMSEpr [ PortReference < <wsa:Address jms://localhost/queue/quickstart_sample_esb/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : localhost/>, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:con
                    nection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : 1/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/jms/> > ] ReplyTo: JMSEpr [ PortReference < <wsa:Address jms://localhost/queue/quickstart_sample_esb_reply/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : localhost/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.interfaces.NamingContextFact
                    ory/>, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:message-selector : jbossESBresponseUUID='ef2008c0-b69b-4cd0-ad0d-21877b2b1607'/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : 1/> > ] ]] to DLQ.
                    18:39:45,172 ERROR [JBossRemotingGatewayListener] JBoss Remoting Gateway failed to synchronously deliver message to target service [SampleCategory:Sample].
                    org.jboss.soa.esb.listeners.message.MessageDeliverException: Failed to deliver message [header: [ To: JMSEpr [ PortReference < <wsa:Address jms://localhost/queue/quickstart_sample_esb/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : localhost/>, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:
                    ReferenceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : 1/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/jms/> > ] ReplyTo: JMSEpr [ PortReference < <wsa:Address jms://localhost/queue/quickstart_sample_esb_reply/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : localhost/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.
                    jnp.interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:message-selector : jbossESBresponseUUID='ef2008c0-b69b-4cd0-ad0d-21877b2b1607'/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : 1/> > ] ]] to Service [SampleCateg
                    ory:Sample]. Check for errors.
                     at org.jboss.soa.esb.client.ServiceInvoker.post(ServiceInvoker.java:279)
                     at org.jboss.soa.esb.client.ServiceInvoker.deliverSync(ServiceInvoker.java:155)
                     at org.jboss.soa.esb.listeners.message.UncomposedMessageDeliveryAdapter.deliverSyncWithoutDecomposing(UncomposedMessageDeliveryAdapter.java:107)
                     at org.jboss.soa.esb.listeners.message.UncomposedMessageDeliveryAdapter.deliverSync(UncomposedMessageDeliveryAdapter.java:86)
                     at org.jboss.soa.esb.listeners.gateway.JBossRemotingGatewayListener.invoke(JBossRemotingGatewayListener.java:316)
                     at org.jboss.remoting.ServerInvoker.invoke(ServerInvoker.java:769)
                     at org.jboss.remoting.transport.coyote.CoyoteInvoker.service(CoyoteInvoker.java:310)
                     at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
                     at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
                     at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:446)
                     at java.lang.Thread.run(Thread.java:595)
                    18:39:52,097 WARN [MessageAwareListener] Error processing courier, backing off for 32000 milliseconds
                    


                    Please help to resolve the issue.

                    Thanks,
                    Puneet

                    • 7. Re: (Please Reply) Help Needed Urgently to configure jbr pro
                      Puneet Jain Newbie

                      Please reply. Any reply will be appreciated.
                      I need help very urgently

                      Thanks in Advanced

                      • 8. Re: Help Needed Urgently to configure jbr provider
                        Daniel Bevenius Master

                        Hi Puneet,

                        are you able to run the webservice_producer quickstart?
                        I'd suggest you start by trying it and the modifying it suite your needs. Removing things you don't need and adding new things step by step.

                        Regards,

                        Daniel

                        • 9. Re: (Please Reply) Help Needed Urgently to configure jbr pro
                          Tom Fennelly Master

                           

                          "puneetjain" wrote:
                          Please reply. Any reply will be appreciated.
                          I need help very urgently

                          Thanks in Advanced


                          Dude... you really need to read the docs and try out some of the basic quickstarts first.

                          You'll have a much better chance of getting help here if people get the impression you've done a little homework yerself first ;-)