2 Replies Latest reply on May 12, 2008 4:48 AM by Kevin Conner

    Urgent assistance required: Issue with accessing the web ser

    raghavendra naik Newbie

      Hi,

      We have two Services deployed in ESB server. the jboss-esb.xml providers section is as below.. we are using localhost.

      
      
       <providers>
       <jms-provider name="JBossMQ" connection-factory="ConnectionFactory"
       jndi-context-factory="org.jnp.interfaces.NamingContextFactory"
       jndi-URL="localhost">
      
       <jms-bus busid="quickstartGwChannel">
       <jms-message-filter dest-type="QUEUE" dest-name="queue/quickstart_webservice_producer_gw"/>
       </jms-bus>
       <jms-bus busid="quickstartEsbChannel">
       <jms-message-filter dest-type="QUEUE" dest-name="queue/quickstart_webservice_producer_esb"/>
       </jms-bus>
       </jms-provider>
      
       <jbr-provider name="JBR-Http" protocol="http" host="localhost">
       <jbr-bus busid="Http-1" port="8292" />
       </jbr-provider>
      
       </providers>
      
      



      The other service Jboss-esb.xml is similar only the port for http-1 we changed to 8293

      We have another client component which is the web-app. When we depploy the web-app in the same jboss-esb server. We donot face any problem. But when we deploy it in a different machine. we are not able to invoke the end points. I tried telnet 8292 and 8293 ... i get cannot connet : connect failed.

      I am starting the Jboss ESB using: run.bat -b 0.0.0.0

      I am very new to JBoss and any assistance in this regard would be very helpful.

      Thanks
      R.Naik