4 Replies Latest reply on Jul 3, 2008 4:11 PM by a francis

    ESB Message Trouble

    a francis Newbie

      Hi,

      I'm using the JBoss SOA-P 4.2 distribution. I got the helloworld demo working with ant, but was now trying to get it to run in eclipse so I can developing my own app, like in the ESB Programmers Guide. However, I am running into problems with the Message object (org.jboss.soa.message) in SendEsbMessage.java. If I try including the default client libraries, it can't be found. I have tried including jbossesb-rosetta in \deploy\jbossesb.sar\lib but then I get no class definition for an com.arjuna object. Can anyone point me in the right direction? Thanks.

        • 1. Re: ESB Message Trouble
          Daniel Bevenius Master

          Hi,

          I've tried this and this is the what my .classpath file looks like:

          <?xml version="1.0" encoding="UTF-8"?>
          <classpath>
           <classpathentry kind="src" path="src"/>
           <classpathentry excluding="src/" kind="src" path=""/>
           <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
           <classpathentry kind="lib" path="/JBossESB-trunk/build/jbossesb/lib/jbossesb-rosetta.jar" sourcepath="/JBossESB-trunk/rosetta"/>
           <classpathentry kind="lib" path="/JBossESB-trunk/build/jbossesb/lib/jbossesb-config-model-1.0.1.jar"/>
           <classpathentry kind="lib" path="/JBossESB-trunk/lib/ext/wstx-lgpl-3.2.1.jar"/>
           <classpathentry kind="lib" path="/JBossESB-trunk/lib/ext/jboss-aop-jdk50.jar"/>
           <classpathentry kind="lib" path="/JBossESB-trunk/lib/ext/jboss-messaging-client.jar"/>
           <classpathentry kind="lib" path="/JBossESB-trunk/lib/ext/jboss-remoting.jar"/>
           <classpathentry kind="lib" path="/JBossESB-trunk/lib/ext/xbean.jar"/>
           <classpathentry kind="lib" path="/JBossESB-trunk/lib/ext/jbossts-common.jar"/>
           <classpathentry kind="lib" path="/JBossESB-trunk/lib/ext/stax-api-1.0.1.jar"/>
           <classpathentry kind="lib" path="/JBossESB-trunk/lib/ext/scout-1.0rc1.jar"/>
           <classpathentry kind="lib" path="/JBossESB-trunk/lib/ext/commons-logging-1.0.4.jar"/>
           <classpathentry kind="lib" path="/JBossESB-trunk/lib/ext/jbossall-client.jar" sourcepath="/opt/jboss/as/jboss-4.2.1.GA-src"/>
           <classpathentry kind="lib" path="/JBossESB-trunk/lib/ext/juddi-client-2.0rc5.jar"/>
           <classpathentry kind="lib" path="/JBossESB-trunk/lib/ext/xercesImpl-2.7.1.jar"/>
           <classpathentry kind="lib" path="/JBossESB-trunk/lib/ext/jaxr-api-1.0rc1.jar"/>
           <classpathentry kind="lib" path="/JBossESB-trunk/lib/ext/jsr173_1.0_ri.jar"/>
           <classpathentry kind="lib" path="/JBossESB-trunk/lib/ext/commons-codec-1.3.jar"/>
           <classpathentry kind="output" path="bin"/>
          </classpath>
          

          These were needed to run both SendJMSMessage and SendEsbMessage. If you only are running SendJMSMessage then the classpath can be reduced.

          SendEsbMessage I ran with with the following program arguments:
          FirstServiceESB SimpleListener "Hello World"


          The paths in the .classpath will not be the same but you can see which were needed.

          Regards,

          /Daniel

          • 2. Re: ESB Message Trouble
            a francis Newbie

            OK, added all those jars in and it compiles and runs now but i'm unfortunately not getting the expected behavior.

            Before I reordered the jars - i was getting this: ERROR [BisocketServerInvoker] received new control socket for unrecognized listenerId: 5c4o6y5l-5q39mn-fi7p4qt5-1-fi7p4rai-7

            After I reordered the jars, it just hangs, with no output on the server. This is the behavior for both SendEsbMessage and SendJMSMessage

            • 3. Re: ESB Message Trouble
              Daniel Bevenius Master


              Do you mean that you reordered the jars so that they as they were specified in my post?

              If you have the same order as in the previous post, please make sure that the jboss-messaging-client.jar and jboss-remoting.jar are the same version that the JBoss SOA-P 4.2 distribution uses.

              Regards,

              Daniel

              • 4. Re: ESB Message Trouble
                a francis Newbie

                Yep, that did it. I switched over jboss-remoting.jar and jboss-messaging-client.jar to the jboss-soa-p\client folder and that did the trick. Thanks for your help.