14 Replies Latest reply on Dec 12, 2008 5:29 AM by Kevin Conner

    Installing JBoss ESB, "Could not determine JMS provider"

    Scott Lindner Newbie

      I am trying to install JBoss ESB v4.4 onto JBossAS 4.2.2.GA and am experiencing the error described in this documented bug, https://jira.jboss.org/jira/browse/JBESB-1895

      The resolution does not work in my situation. Is there something else that I can try besides a complete OS rebuild and starting from scratch?

      Cheers,
      Scott

        • 1. Re: Installing JBoss ESB,
          Daniel Bevenius Master

          Hi Scott,

          Can you check if the path specified in 'org.jboss.esb.server.home' contains a space. I think I remember this being a issue on windows. Are you running windows by the way?

          Regards,

          /Daniel

          • 2. Re: Installing JBoss ESB,
            Scott Lindner Newbie

            There are no spaces in the path.

            Any other thoughts on how to debug this issue? It is giving an error, but I have no clue how to trace down the cause. I have followed the instuctions to resolve this issue from the bug I listed earlier. The only thought I have to try is to resinstall everything on a freshly installed OS and try again. Since this was a clean OS to begin with, and all I installed was JBossAS 4.2.2 and JBoss ESB 4.4, I doubt I messed the OS up.

            • 3. Re: Installing JBoss ESB,
              Tom Fennelly Master

              Please post your config.

              • 4. Re: Installing JBoss ESB,
                Scott Lindner Newbie

                org.jboss.esb.server.home=C:/JBoss/jbossesb-4.4.GA
                org.jboss.esb.server.config=default

                • 5. Re: Installing JBoss ESB,
                  Martin Vecera Novice

                  What about a space at the end of the line. It caused me a big trouble another time...

                  • 6. Re: Installing JBoss ESB,
                    Scott Lindner Newbie

                    I double checked, no extra white space anywhere in the config file.

                    • 7. Re: Installing JBoss ESB,
                      Daniel Bevenius Master

                      Can you add the following echo to install/build.xml:

                      <property name="product.dir" location=".."/>
                      
                      <echo message="deploy.dir : '${deploy.dir}'"/>
                       <echo message="hadeploy.dir : '${hadeploy.dir}'"/>
                      
                      


                      The above property, deploy.dir, will point to your servers configured deploy directory as specified in deployment.properties.
                      It will look for the presents of any of the following files in the deploy directory:
                      jboss-messaging
                      jboss-messaging.sar
                      jms/jbossmq-service.xml

                      And also check the hadeploy directory for:
                      jms/jbossmq-service.xml

                      If none of those are found you will get the message you are seeing "Could not determine JMS provider".

                      Can you try that and post the output after adding the echos to the ant build.xml.

                      Thanks,

                      /Daniel




                      • 8. Re: Installing JBoss ESB,
                        Scott Lindner Newbie

                        I added those lines at the very end of the build.xml within the Project tag.


                        Buildfile: build.xml
                        [echo] deploy.dir : 'C:/JBoss/jbossesb-4.4.GA/server/default/deploy'
                        [echo] hadeploy.dir : 'C:/JBoss/jbossesb-4.4.GA/server/default/deploy-hasingleton'

                        check.deploy.props:

                        dependencies.source:

                        dependencies.jbossesb:

                        dependencies:

                        jms.config.check:

                        BUILD FAILED
                        C:\JBoss\jbossesb-4.4.GA\install\build.xml:70: Could not determine JMS provider

                        Total time: 0 seconds


                        • 9. Re: Installing JBoss ESB,
                          Scott Lindner Newbie

                          Shoot. I forgot to answer your last question.

                          The hadedeploy directory does not exist. If I were to remove the "-hasingleton" from the end of the path, then the directory would exist, and the path to the jms/jbossmq--service.xml would be valid. I suspect this is the problem. What is telling the install to add the "-hasingleton" to the end?

                          Scott

                          • 10. Re: Installing JBoss ESB,
                            Scott Lindner Newbie

                            Thanks so much. The debug code helped me nail down the problem. I was pointing to the JBossESB directory for the installation files, not the target directory in the JBossAS.

                            Thanks again. The debug code really helped me nail this down.

                            Cheers,
                            Scott

                            • 11. Re: Installing JBoss ESB,
                              Bernd Putsche Newbie

                              one problem i also have is indeed the hadeploy, since the default configuration has no singleton deploy dir!

                              it's of no use since there are no cluster services deployed in this configuration there is no need to seperate de deploy and singleton deploy.

                              so maybe just commenting OUT the jms check on hadeploy line 68 and 69 in build.xml or setting hadeploy.dir = deploy.dir should solve the problem regarding jms check and default configuration.

                              cheers,
                              bernd

                              • 12. Re: Installing JBoss ESB,
                                Bernd Putsche Newbie

                                ups... my mistake...

                                of course it works also with hadeploy..

                                i apologize if i screwed up somebody with my previos post! i got another error in my config, thats why it did not work!

                                cheers
                                bernd

                                • 13. Re: Installing JBoss ESB,
                                  Benu Gupta Newbie

                                  Hi,

                                  I am trying to deploy JBoss ESB 4.4 to a clean installation of JBoss AS 5.0. I get the same error as above when i run the ant file in install directory. After debugging it for a while I realized, its looking for jboss-messaging , jboss-messaging.sar and some other files in the deploy dir of the JBoss AS. But there are no such files. Its the same problem as reported in JIRA issue - JBESB-1022.

                                  Am I missing something here? Any help would be greatly appreciated.

                                  Thanks.

                                  • 14. Re: Installing JBoss ESB,
                                    Kevin Conner Master

                                    We have not yet tried the ESB with AS 5, it has only been tested/installed into AS 4.

                                    You should be able to install it into AS5 but I would be very surprised if it ran without error. I would expect some work on our part before this would be possible.