2 Replies Latest reply on Nov 5, 2008 9:53 AM by Daniel Bevenius

    Trailblazer deployment fails

    Ivan Teixeira Newbie

      Hello,

      I am trying to deploy Trailblazer but I get the following error during "ant deploy":

      BUILD FAILED
      /usr/local/soa/jbossesb-4.4.GA/samples/trailblazer/build.xml:172: /usr/local/soa/jbossesb-4.4.GA/samples/trailblazer/client/lib/ext not found.





      I have everything configured as described in the readme.txt, including the deployment.properties pointing to the JBoss Server + ESB in the variable org.jboss.esb.server.home.


      This is the same error reported in this post, without any reply:


      Deploying Trailblazer
      http://www.jboss.com/index.html?module=bb&op=viewtopic&t=142748

      I tried to create de missing folder only to fall to the following compile errror:

      esb.compile:
      [javac] Compiling 6 source files to /usr/local/soa/jbossesb-4.4.GA/samples/trailblazer/esb/build/classes
      [javac] /usr/local/soa/jbossesb-4.4.GA/samples/trailblazer/esb/src/org/jboss/soa/esb/samples/trailblazer/util/ProcessEmail.java:28: package org.antlr.stringtemplate does not exist
      [javac] import org.antlr.stringtemplate.StringTemplate;
      [javac] ^
      [javac] /usr/local/soa/jbossesb-4.4.GA/samples/trailblazer/esb/src/org/jboss/soa/esb/samples/trailblazer/util/ProcessEmail.java:29: package org.antlr.stringtemplate does not exist
      [javac] import org.antlr.stringtemplate.StringTemplateGroup;
      [javac] ^
      [javac] /usr/local/soa/jbossesb-4.4.GA/samples/trailblazer/esb/src/org/jboss/soa/esb/samples/trailblazer/util/ProcessEmail.java:79: cannot find symbol


      I searched more about this in JBoss ESB Jira to find this issue, assumed closed:


      JBESB-1718

      https://jira.jboss.org/jira/browse/JBESB-1718;jsessionid=F6C74F2BCFEE299D6F7AD551F2274252?page=com.atlassian.jira.plugin.system.issuetabpanels%3Aall-tabpanel

      It seens like Kevin Conner was fixing another build issue in trailblazer and doing so he removed all client/lib/ext from tralblazer in revision 19968. I think he changed the sample build to depend upon the libs from JBoss Server + ESB install folder. But the problem is that this sample just won't build and deploy since release 4.3 GA as far as I looked.

      Can anyone help building and deploying Trailblazer? Should a Jira issue be created about this or am I missing something here ?